aboutsummaryrefslogtreecommitdiff
path: root/recipes-containers/lxc
diff options
context:
space:
mode:
authorBogdan Purcareata <bogdan.purcareata@freescale.com>2013-04-11 12:20:06 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-04-11 13:07:27 -0700
commit73809e88a25084604ef80167619f1fbe90d95286 (patch)
treec20f98e5f122449816c3ae0a2dffd2a4c3c1a561 /recipes-containers/lxc
parent6f1446097d819740da9eb3e1376fd718eebb37e9 (diff)
lxc: Update LXC recipe to include config examples in main package
The patch configures the LXC recipe to include configuration examples or containers in the default package - lxc, not in the documentation one - lxc-doc. By default, bitbake will split a specific package into multiple sections, based on meaning - binaries, libraries, documentation, configs, etc. The sections will then be assembled into individual packages, such as e.g lxc, lxc-doc, lxc-dbg and so on. The packages are mutually exclusive with respect to the sections they contain. LXC installation provides several example configuration files for various usage scenarios. The twist is that LXC build scripts place these config examples in a relative path that is identified by bitbake as belonging to documentation. This patch places these configuration files in the main package, where they normally belong. Signed-off-by: Bogdan Purcareata <bogdan.purcareata@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/lxc')
-rw-r--r--recipes-containers/lxc/lxc_0.9.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_0.9.0.bb b/recipes-containers/lxc/lxc_0.9.0.bb
index 1d6ce71..fcda0ba 100644
--- a/recipes-containers/lxc/lxc_0.9.0.bb
+++ b/recipes-containers/lxc/lxc_0.9.0.bb
@@ -36,4 +36,7 @@ PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparm
inherit autotools
+FILES_${PN}-doc = "${mandir} ${infodir}"
+# For LXC the docdir only contains example configuration files and should be included in the lxc package
+FILES_${PN} += "${docdir}"
FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"