aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Yang <lei.yang@windriver.com>2013-05-29 14:55:13 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-05-30 16:56:01 -0400
commite3fd5715e39115c00fea4d17adce180e7f2b2ff7 (patch)
treeaed8dd3f08d636c884330d91c0c26844acf2fef1
parentc817a8b660b15825ede58c45da5f60a8e0db24c3 (diff)
libvirt: Enable selinux if selinux is available
Enable selinux when "DISTRO_FEATURES" contains selinux Signed-off-by: Lei Yang <lei.yang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index 989b8b1..b0a4e0a 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -112,7 +112,7 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
# full config
PACKAGECONFIG ??= "qemu yajl xen libxl xen-inotify uml openvz vmware vbox esx \
- polkit lxc test remote macvtap libvirtd netcf udev python"
+ polkit lxc test remote macvtap libvirtd netcf udev python ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu"
PACKAGECONFIG[yajl] = "--with-yajl,--without-yajl,yajl,yajl"
@@ -136,7 +136,7 @@ PACKAGECONFIG[libvirtd] = "--with-libvirtd,--without-libvirtd"
PACKAGECONFIG[netcf] = "--with-netcf,--without-netcf,netcf,netcf"
PACKAGECONFIG[dtrace] = "--with-dtrace,--without-dtrace,,"
PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess,"
-
+PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
# Enable the Python tool support
require libvirt-python.inc