aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2013-07-13 12:11:32 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-07-13 23:06:12 -0400
commit8b2a6e65c6abf256e802f728d44a0d05db5ea53b (patch)
treea4077e395703e0f1469d4e086eb8662e2fd57a89
parent84ff6d7447695b3639b71e05d705667aca659608 (diff)
lxc: create lxc cache directory
Many LXC templates expect the cache directory to exist and use it without necessarily checking if it exists. Normally the Makefile would create this directory but since /var/cache is volatile we must use the volatile system to create this directory at boot, or when the package is installed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/lxc/lxc_0.9.0.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-containers/lxc/lxc_0.9.0.bb b/recipes-containers/lxc/lxc_0.9.0.bb
index 30316bb..563131f 100644
--- a/recipes-containers/lxc/lxc_0.9.0.bb
+++ b/recipes-containers/lxc/lxc_0.9.0.bb
@@ -3,7 +3,7 @@ SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
PRIORITY = "optional"
-PR = "r2"
+PR = "r3"
DEPENDS = "libxml2 libcap"
RDEPENDS_${PN} = " \
rsync \
@@ -47,3 +47,19 @@ FILES_${PN}-doc = "${mandir} ${infodir}"
# For LXC the docdir only contains example configuration files and should be included in the lxc package
FILES_${PN} += "${docdir}"
FILES_${PN}-dbg += "${libexecdir}/lxc/.debug"
+
+do_install_append() {
+ # The /var/cache/lxc directory created by the Makefile
+ # is wiped out in volatile, we need to create this at boot.
+ rm -rf ${D}${localstatedir}/cache
+ install -d ${D}${sysconfdir}/default/volatiles
+ echo "d root root 0755 ${localstatedir}/cache/lxc none" \
+ > ${D}${sysconfdir}/default/volatiles/99_lxc
+
+}
+
+pkg_postinst_${PN}() {
+ if [ -z "$D" ] && [ -e /etc/init.d/populate-volatile.sh ] ; then
+ /etc/init.d/populate-volatile.sh update
+ fi
+}