aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMihai Prica <mihai.prica@intel.com>2013-04-18 18:10:42 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-04-18 21:39:24 -0700
commit7040db74c375ef55d1b040f53071be29590882de (patch)
tree250ef94cefe1a2f54a29b57d3a666637bb7ce517
parent3413d7e8b8f45996230ee1931bdf224952d88a19 (diff)
libvirt: Changed python bindings install location
The libvirt-python files were installed to dist-packages and this is not part of sys.path in yocto so they were not available to python. Changed this to site-packages. Signed-off-by: Mihai Prica <mihai.prica@intel.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt-python.inc4
-rw-r--r--recipes-extended/libvirt/libvirt/python_incdir.patch15
2 files changed, 11 insertions, 8 deletions
diff --git a/recipes-extended/libvirt/libvirt-python.inc b/recipes-extended/libvirt/libvirt-python.inc
index 49d15fb..297e90c 100644
--- a/recipes-extended/libvirt/libvirt-python.inc
+++ b/recipes-extended/libvirt/libvirt-python.inc
@@ -10,5 +10,5 @@ RDEPENDS_${PN}-python += "python"
PACKAGECONFIG_${PN}-python[xen] = ",,,xen-python"
PACKAGES += "${PN}-python-dbg ${PN}-python"
-FILES_${PN}-python-dbg += "${libdir}/${PYTHON_DIR}/dist-packages/.debug/"
-FILES_${PN}-python += "${libdir}/${PYTHON_DIR}/dist-packages"
+FILES_${PN}-python-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug/"
+FILES_${PN}-python += "${libdir}/${PYTHON_DIR}/site-packages"
diff --git a/recipes-extended/libvirt/libvirt/python_incdir.patch b/recipes-extended/libvirt/libvirt/python_incdir.patch
index 6c77b09..5b78c13 100644
--- a/recipes-extended/libvirt/libvirt/python_incdir.patch
+++ b/recipes-extended/libvirt/libvirt/python_incdir.patch
@@ -1,8 +1,8 @@
-Index: libvirt-0.10.2/configure.ac
+Index: libvirt-1.0.3/configure.ac
===================================================================
---- libvirt-0.10.2.orig/configure.ac 2012-10-29 11:59:27.091615491 +0200
-+++ libvirt-0.10.2/configure.ac 2012-10-29 12:09:50.067603647 +0200
-@@ -2397,6 +2397,11 @@
+--- libvirt-1.0.3.orig/configure.ac
++++ libvirt-1.0.3/configure.ac
+@@ -1878,6 +1878,11 @@ fi
PYTHON_VERSION=
PYTHON_INCLUDES=
@@ -14,9 +14,12 @@ Index: libvirt-0.10.2/configure.ac
if test "$with_python" != "no" ; then
if test -x "$with_python/bin/python"
then
-@@ -2422,29 +2427,30 @@
- AM_PATH_PYTHON(,, [:])
+@@ -1901,31 +1906,32 @@ if test "$with_python" != "no" ; then
+ if test "$with_python" = "yes" ; then
+ AM_PATH_PYTHON(,, [:])
+-
++ pyexecdir=$prefix/lib/python$PYTHON_VERSION/site-packages
if test "$PYTHON" != : ; then
- PYTHON_CONFIG="$PYTHON-config"
-