aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTing Liu <b28495@freescale.com>2013-05-23 17:57:15 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-05-24 21:01:45 -0700
commit69a10f062a0cd8c054b495ccb303fea50e4c592d (patch)
tree925463d6e962a6db6f4d88c959b6df5c959b807c
parent98093ac9ab99d11c4e549436eb0abcef438fb6ce (diff)
netcf: fix network driver check issue on opensuse
Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch28
-rw-r--r--recipes-networking/netcf/netcf_git.bb6
2 files changed, 32 insertions, 2 deletions
diff --git a/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch b/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch
new file mode 100644
index 0000000..eef5b5c
--- /dev/null
+++ b/recipes-networking/netcf/netcf/0001-fix-network-driver-check-issue-on-opensuse.patch
@@ -0,0 +1,28 @@
+From 285871a2db42727665a2ab7fc16fa2fb8fa830d3 Mon Sep 17 00:00:00 2001
+From: Ting Liu <b28495@freescale.com>
+Date: Thu, 23 May 2013 17:39:35 +0800
+Subject: [PATCH] fix network driver check issue on opensuse
+
+Upstream-Status: Pending
+
+Signed-off-by: Ting Liu <b28495@freescale.com>
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3f30865..708eb28 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -77,7 +77,7 @@ fi
+ if test "x$with_driver" = "xcheck" && test -f /etc/ubuntu_version ; then
+ with_driver=debian
+ fi
+-if test "x$with_driver" = "xcheck" && test -f /etc/suse-release ; then
++if test "x$with_driver" = "xcheck" && (test -f /etc/suse-release || test -f /etc/SuSE-release) ; then
+ with_driver=suse
+ fi
+ if test "x$with_driver" = "xcheck" ; then
+--
+1.7.3.4
+
diff --git a/recipes-networking/netcf/netcf_git.bb b/recipes-networking/netcf/netcf_git.bb
index 60fc446..d380e95 100644
--- a/recipes-networking/netcf/netcf_git.bb
+++ b/recipes-networking/netcf/netcf_git.bb
@@ -7,10 +7,12 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=bbb461211a33b134d42ed5ee802b37ff"
SRCREV = "2b0d9ca226c13d7150382367f62b256bdb2db5ef"
-PR = "r0"
+PR = "r1"
PV = "0.2.2+git${SRCPV}"
-SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git"
+SRC_URI = "git://git.fedorahosted.org/netcf.git;protocol=git \
+ file://0001-fix-network-driver-check-issue-on-opensuse.patch \
+"
DEPENDS += "augeas libnl libxslt libxml2"