aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-04-18 21:31:00 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-04-18 21:36:00 -0700
commit273bdbaa50179af05047723a44289f97b2dd7d8f (patch)
treeda6b6d1d171ac59fabc02535ca082289d62c0bae
parentc6af28f6e7af3959495deada7f5210a47ee4d7f9 (diff)
libvirt: use pkgconfig to control udev
To ensure that libvirt doesn't rely on detection of udev in the environment or sysroot we can add a PACKAGECONFIG option to control both the enablement of udev support, and ensure that libpciaccess is added as a dependency, otherwise configure detects issues such as this: | checking for UDEV... yes | configure: error: You must install the pciaccess module to build with udev | Configure failed. The contents of all config.log files follows to aid debugging Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index c1c000e..f341924 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://libvirt.org"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb919cc88dbe06ec0b0bd50e001ccf1f"
SECTION = "console/tools"
-PR = "r1"
+PR = "r2"
DEPENDS = "bridge-utils gnutls libxml2 lvm2 avahi parted curl libpcap util-linux e2fsprogs pm-utils \
iptables ebtables dnsmasq readline"
@@ -106,7 +106,7 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
# full config
PACKAGECONFIG ??= "qemu yajl xen libxl xen-inotify uml openvz vmware vbox esx \
- polkit lxc test remote macvtap libvirtd netcf"
+ polkit lxc test remote macvtap libvirtd netcf udev"
PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu"
PACKAGECONFIG[yajl] = "--with-yajl,--without-yajl,yajl,yajl"
@@ -129,6 +129,7 @@ PACKAGECONFIG[macvtap] = "--with-macvtap=yes,--with-macvtap=no,libnl,libnl"
PACKAGECONFIG[libvirtd] = "--with-libvirtd,--without-libvirtd"
PACKAGECONFIG[netcf] = "--with-netcf,--without-netcf,netcf,netcf"
PACKAGECONFIG[dtrace] = "--with-dtrace,--without-dtrace,,"
+PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess,"
# Enable the Python tool support
require libvirt-python.inc