aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2014-02-21 17:13:42 -0600
committerTom Gall <tom.gall@linaro.org>2014-02-21 17:13:42 -0600
commit8a07c596f19563bcb0214ecb2c7d90b72d14bc66 (patch)
tree7cacd5fdf99e841e3426f83250b409fbdcb83238
parent32d576602420fbc14c5c0126d8986ae946fcbf6f (diff)
Add criu which contains two packages, protobuf and protobuf-c which is an implementation ofarmv8-xfce
Protocol Buffers. Protocol Buffers are a way of encoding structured data in an efficient yet extensible format. Google uses Protocol Buffers for almost all of its internal RPC protocols and file formats.
-rw-r--r--meta-linaro/recipes-devtools/criu/protobuf-c_0.15.bb20
-rw-r--r--meta-linaro/recipes-devtools/criu/protobuf_2.4.1.bb18
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-linaro/recipes-devtools/criu/protobuf-c_0.15.bb b/meta-linaro/recipes-devtools/criu/protobuf-c_0.15.bb
new file mode 100644
index 0000000..d9d4fd9
--- /dev/null
+++ b/meta-linaro/recipes-devtools/criu/protobuf-c_0.15.bb
@@ -0,0 +1,20 @@
+SUMMARY = "protobuf-c"
+DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C"
+HOMEPAGE = "http://code.google.com/p/protobuf-c/"
+SECTION = "console/tools"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://src/google/protobuf-c/protobuf-c.c;endline=33;md5=333140fae7cf8a38dc5f980ddb63704b"
+
+PR = "r0"
+
+DEPENDS = "protobuf"
+
+SRC_URI[md5sum] = "73ff0c8df50d2eee75269ad8f8c07dc8"
+SRC_URI[sha256sum] = "8fcb538e13a5431c46168fc8f2e6ad2574e2db9b684c0c72b066e24f010a0036"
+SRC_URI = "http://protobuf-c.googlecode.com/files/protobuf-c-${PV}.tar.gz \
+ file://disable_tests.patch"
+
+inherit autotools
+
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file
diff --git a/meta-linaro/recipes-devtools/criu/protobuf_2.4.1.bb b/meta-linaro/recipes-devtools/criu/protobuf_2.4.1.bb
new file mode 100644
index 0000000..d8f1b53
--- /dev/null
+++ b/meta-linaro/recipes-devtools/criu/protobuf_2.4.1.bb
@@ -0,0 +1,18 @@
+SUMMARY = "protobuf"
+DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an efficient yet extensible format. Google uses Protocol Buffers for almost all of its internal RPC protocols and file formats."
+HOMEPAGE = "http://code.google.com/p/protobuf/"
+SECTION = "console/tools"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=af6809583bfde9a31595a58bb4a24514"
+
+PR = "r0"
+
+SRC_URI[md5sum] = "dc84e9912ea768baa1976cb7bbcea7b5"
+SRC_URI[sha256sum] = "eac6969b617f397247e805267da2b0db3ff9e5a9163b123503a192fbb5776567"
+SRC_URI = "http://protobuf.googlecode.com/files/protobuf-${PV}.tar.gz"
+
+EXTRA_OECONF += " --with-protoc=echo"
+inherit autotools
+
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file