aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGergely Risko <gergely+context@risko.hu>2009-06-23 18:23:04 +0300
committerGergely Risko <gergely+context@risko.hu>2009-06-23 18:23:04 +0300
commit5ddc97857ab9823940bd9ca6b159be9fa274f87d (patch)
tree9dfb4e7de96361c8bc8168d171454a4bc7865858 /Makefile.am
parent4304144db18537f24a486ac3d28753ab8583d34a (diff)
build cleanup: support for top-level check-sum, check-accept and coverage
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ea1c2fe4..1fbc4b3b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,12 @@ pkgconfig_DATA = contextprovider-1.0.pc
EXTRA_DIST = contextprovider-1.0-uninstalled.pc
DISTCLEANFILES = lcov.info lcov.html
MAINTAINERCLEANFILES = INSTALL
+
+check-sum:
+ $(MAKE) -C libcontextsubscriber/unit-tests check-sum
+
+check-accept:
+ $(MAKE) -C libcontextsubscriber/accept-tests check-accept
+
+coverage:
+ $(MAKE) -C libcontextsubscriber/unit-tests coverage