aboutsummaryrefslogtreecommitdiff
path: root/tests/egl/spec/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-07-23 09:54:18 -0700
committerMatt Turner <mattst88@gmail.com>2012-08-24 16:25:39 -0700
commit5af7535edd12c9c661830eabd6b244e9740b4e46 (patch)
tree0e1321d2519800bd7b51b036c1a53608dcfe05dd /tests/egl/spec/CMakeLists.txt
parent15223f787647e93363fcd9c2d7789676b3d9b69d (diff)
egl_khr_create_context: Add common test infrastructure
v2: - Require EGL_KHR_surfaceless_context instead of other surfaceless extensions. - Fix for-loop typo. - Make EGL_KHR_create_context_setup take a renderable_type_mask argument. - Make EGL_KHR_create_context_setup return whether it succeeded. - PIGLIT_SKIP if eglChooseConfig fails (in the case of requesting an ES 1.x context when 1.x isn't supported). - Add version_is_valid_for_context helper function.
Diffstat (limited to 'tests/egl/spec/CMakeLists.txt')
-rw-r--r--tests/egl/spec/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/egl/spec/CMakeLists.txt b/tests/egl/spec/CMakeLists.txt
new file mode 100644
index 00000000..de4de3f0
--- /dev/null
+++ b/tests/egl/spec/CMakeLists.txt
@@ -0,0 +1 @@
+add_subdirectory (egl_khr_create_context)