aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Paul <brianp@vmware.com>2012-06-27 16:24:28 -0600
committerBrian Paul <brianp@vmware.com>2012-06-28 12:45:55 -0600
commit4a14d11dbaced794fd8a9468e0d5c28c82a762ca (patch)
treed13739acf61f86e0e999d12f167139ae287d0a8a /tests/CMakeLists.txt
parent06fb2c385ec6b026e1800f2f6f0c2b0cf5c3d760 (diff)
security/initialized-texmemory - test contents of unitialized texture memory
This is the first of a new category of piglit tests that exercise things related to security. The first test, initialized-texmemory, creates a texture image with unspecified contents (pixels=NULL). We draw a polygon with the texture and see what we get. Ideally, we'd get a constant/black image and not some random VRAM data from another application or another user (like a window image). The OpenGL spec doesn't say that texture memory should be initialized in this situation so if the test fails we return "WARN" rather than "FAIL". Reviewed-by: José Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1a53693b..05824b47 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -12,6 +12,7 @@ add_subdirectory (glx)
add_subdirectory (glslparsertest)
add_subdirectory (hiz)
add_subdirectory (asmparsertest)
+add_subdirectory (security)
add_subdirectory (shaders)
add_subdirectory (texturing)
add_subdirectory (spec)