aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2014-07-29 14:13:42 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2014-07-29 18:13:49 +0400
commitb8d16ef019afdd2371eca3645e61704098d19220 (patch)
treea8018cf30f36851e27f0c2f7e5084c6cddfe54d6 /configure.ac
parente5346dfee9f9a6d599766b93fe5b4e313bcdfe16 (diff)
configure.ac: add sdk-install-path variable
Makes it easier for external libs and headers if they aren't in the default path. Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Reviewed-and-Tested-by: Taras Kondratiuk <taras.kondratiuk@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97089e9f..37918025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,15 @@ AC_ARG_WITH([platform],
AC_SUBST([with_platform])
+AC_ARG_WITH([sdk-install-path],
+AC_HELP_STRING([--with-sdk-install-path=DIR Path to external libs and headers],
+ [(or in the default path if not specified).]),
+[SDK_INSTALL_PATH=$withval SDK_INSTALL_PATH_=1],[SDK_INSTALL_PATH_=])
+
+AC_SUBST(SDK_INSTALL_PATH)
+
+AM_CONDITIONAL([SDK_INSTALL_PATH_], [test "x${SDK_INSTALL_PATH_}" = "x1"])
+
##########################################################################
# Enable/disable netmap support
##########################################################################