aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2014-08-24 13:55:54 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2014-08-25 19:18:45 +0400
commit99c87e985a6ca17fc38a697e2034a3786f2e0079 (patch)
tree194682f02748db8ede440b65f1e529ab9fc091a0 /configure.ac
parentc28cf78818b17318e47b06abb0032fddf9b996d7 (diff)
configure: fix building using flag "--with-openssl-path"
Reported-by: Stuart Haslam <stuart.haslam@arm.com> Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 74713a73..df206902 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,7 +104,7 @@ AC_HELP_STRING([--with-openssl-path=DIR Path to openssl libs and headers],
[(or in the default path if not specified).]),
[OPENSSL_PATH=$withval
AM_CFLAGS="$AM_CFLAGS -I$OPENSSL_PATH/include"
-AM_LDFLAGS="$AM_LDFLAGS -L$OPENSSL_PATH/lib"
+AM_LDFLAGS="$AM_LDFLAGS -L$OPENSSL_PATH/lib -lcrypto"
],[
AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
[AC_MSG_FAILURE([can't find openssl crypto lib])])