aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/Makefile.am
diff options
context:
space:
mode:
authorBill Fischofer <bill.fischofer@linaro.org>2015-09-03 13:59:22 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-09-03 22:57:06 +0300
commit3afd410eaa2e55f47b42508ac0b86390a7b4c711 (patch)
treeaa62d50e24e1cd44f20afabb2de70cdf95127e3c /platform/linux-generic/Makefile.am
parentf1bb82d7e74f5f2f6f7973bade0649b000e69d99 (diff)
linux-generic: general: add odp_forward_typedefs to resolve clang issue
With the addition of ordered queues, there is a circular typedef relationship between odp_queue_internal.h and odp_buffer_internal.h. The standard forward declaration technique that GCC accepts is strictly not acceptable to C99 and is flagged by clang. The solution is to create a common header file that can contain these forward declarations. Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> Reviewed-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'platform/linux-generic/Makefile.am')
-rw-r--r--platform/linux-generic/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/platform/linux-generic/Makefile.am b/platform/linux-generic/Makefile.am
index f2c081a..4c79730 100644
--- a/platform/linux-generic/Makefile.am
+++ b/platform/linux-generic/Makefile.am
@@ -122,6 +122,7 @@ noinst_HEADERS = \
${srcdir}/include/odp_classification_internal.h \
${srcdir}/include/odp_crypto_internal.h \
${srcdir}/include/odp_debug_internal.h \
+ ${srcdir}/include/odp_forward_typedefs_internal.h \
${srcdir}/include/odp_internal.h \
${srcdir}/include/odp_packet_internal.h \
${srcdir}/include/odp_packet_io_internal.h \