aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Milard <christophe.milard@linaro.org>2015-08-06 17:08:18 -0400
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-08-11 12:06:36 +0300
commitf3debf6776d308695b3dc8394154c7e639c71db8 (patch)
tree90a02a10868a22e79a36ad6516bcc5654021a9a0 /configure.ac
parent01f5c738c6e73bd3ad75984d293c506f952a1eff (diff)
doc: implementers-guide: add validation description
Signed-off-by: Christophe Milard <christophe.milard@linaro.org> Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-and-tested-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 24a3fa1..57d145c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,30 @@ fi
AM_CONDITIONAL([HAVE_DOXYGEN], [test "x${DOXYGEN}" = "xdoxygen"])
##########################################################################
+# Check for asciidoc availability
+##########################################################################
+AC_CHECK_PROGS([ASCIIDOC], [asciidoc])
+if test -z "$ASCIIDOC";
+ then AC_MSG_WARN([asciidoc not found - continuing without asciidoc support])
+fi
+
+##########################################################################
+# Enable/disable user guide generation
+##########################################################################
+user_guides=no
+AC_ARG_ENABLE([user-guides],
+ [ --enable-user-guides generate supplemental users guides],
+ [if test "x$enableval" = "xyes"; then
+ if test -z "$ASCIIDOC";
+ then AC_MSG_ERROR([cannot generate user guides without asciidoc])
+ else
+ user_guides=yes
+ fi
+ fi])
+
+AM_CONDITIONAL([user_guide], [test "x${user_guides}" = "xyes" ])
+
+##########################################################################
# Set optional OpenSSL path
##########################################################################
AC_ARG_WITH([openssl-path],
@@ -288,6 +312,7 @@ AM_CXXFLAGS="-std=c++11"
AC_CONFIG_FILES([Makefile
doc/Makefile
+ doc/implementers-guide/Makefile
example/Makefile
example/classifier/Makefile
example/generator/Makefile