aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2015-01-16 21:56:35 +0100
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-01-20 20:11:04 +0300
commitb26c0fb105c99a17735e943dadca4bad9bbe26bf (patch)
treedb0d9eb7546786148675e1f60ca6a17e149c1fa9 /configure.ac
parent5259ee9729556a24dc229a348b4dc91f4e139e95 (diff)
configure.ac: Move library function check
AC_FUNC_MALLOC depends on the paths and gets confused if its not done first. Signed-off-by: Anders Roxell <anders.roxell@linaro.org> Reviewed-and-tested-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-and-tested-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 440cc63..39610ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,11 @@ LT_INIT([])
AC_SUBST([LIBTOOL_DEPS])
AM_PROG_LIBTOOL
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_MMAP
+AC_CHECK_FUNCS([bzero clock_gettime gethostbyname getpagesize gettimeofday memset munmap socket strchr strerror strrchr strstr strtoull])
+
# Checks for header files.
AC_HEADER_RESOLV
AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h unistd.h])
@@ -186,11 +191,6 @@ ODP_CFLAGS="$ODP_CFLAGS -Wformat-security -Wundef -Wwrite-strings"
##########################################################################
AM_CFLAGS="$AM_CFLAGS $ODP_CFLAGS"
-# Checks for library functions.
-AC_FUNC_MALLOC
-AC_FUNC_MMAP
-AC_CHECK_FUNCS([bzero clock_gettime gethostbyname getpagesize gettimeofday memset munmap socket strchr strerror strrchr strstr strtoull])
-
AC_CONFIG_FILES([Makefile
doc/Makefile
example/Makefile