aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2015-08-07 14:00:57 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-08-11 16:00:30 +0300
commita2d4eb703033ba73d8ac0ac2368ce40ab1f44bab (patch)
tree7cc85ab11554f62d802b2853477f7032d07391bd /configure.ac
parent7fff60ad52dd6eded34edfbeb139335c93897b15 (diff)
linux-generic: move pthread checks inside linux-generic
Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org> Reviewed-by: Nicolas Morey-Chaisemartin <morey@kalray.eu> Reviewed-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 5441b4a..bb4ebe0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,8 +153,6 @@ AC_ARG_ENABLE([test-helper],
AM_CONDITIONAL([test_helper], [test x$test_helper = xyes ])
##########################################################################
-
-##########################################################################
# Enable/disable test-cpp
##########################################################################
test_cpp=no
@@ -202,18 +200,6 @@ AC_ARG_ENABLE([debug],
ODP_CFLAGS="$ODP_CFLAGS -DODP_DEBUG=$ODP_DEBUG"
##########################################################################
-# Check for pthreads availability
-##########################################################################
-
-AX_PTHREAD([CC="$PTHREAD_CC"], [
- echo "Error! We require pthreads to be available"
- exit -1
- ])
-LIBS="$PTHREAD_LIBS $LIBS"
-AM_CFLAGS="$AM_CFLAGS $PTHREAD_CFLAGS"
-AM_LDFLAGS="$AM_LDFLAGS $PTHREAD_LDFLAGS"
-
-##########################################################################
# Check for doxygen availability
##########################################################################
AC_CHECK_PROGS([DOXYGEN], [doxygen])
@@ -355,8 +341,6 @@ AC_SEARCH_LIBS([timer_create],[rt posix4])
##########################################################################
# distribute the changed variables among the Makefiles
-AM_LDFLAGS="$AM_LDFLAGS -pthread -lrt"
-
AC_SUBST([LIBS])
AC_SUBST([AM_CPPFLAGS])
AC_SUBST([CPPFLAGS])