aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2015-04-08 21:22:12 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-04-14 12:29:45 +0300
commit920c3dbf9097a78c2b11ec29566006ab4e378016 (patch)
treed7a6746f28709dd859e01d9692bf212ba945d665 /configure.ac
parentfc84fa582f0f453c6bf5979c26f62b3a207c713a (diff)
configure.ac: include configure.m4 if platform explicitly selected
configure script selects linux-generic as default platform and includes platfrom specific configure scripts: ./platform/linux-generic/m4/configure.m4 In case if --with-platfrom=linux-generic was provided to configure platform specific file is not included and that branch of code does not run. This change has to be done for each platform since we have there pktio_env scripts but m4_include macro does not recognize bash variables. So that there is if check. Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org> Reviewed-by: Anders Roxell <anders.roxell@linaro.org> Reviewed-by: Ciprian Barbu <ciprian.barbu@linaro.org> Reviewed-and-tested-by: Mike Holmes <Mike.holmes@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index abe85c0..2c324be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,11 +73,18 @@ AC_ARG_WITH([platform],
[select platform to be used, default linux-generic])],
[],
[with_platform=linux-generic
- m4_include([./platform/linux-generic/m4/configure.m4])
])
AC_SUBST([with_platform])
+if test "${with_platform}" == "linux-generic";
+then
+ m4_include([./platform/linux-generic/m4/configure.m4])
+else
+ echo "UNSUPPORTED PLATFORM: ${with_platform}"
+ exit 1
+fi
+
AC_ARG_WITH([sdk-install-path],
AC_HELP_STRING([--with-sdk-install-path=DIR path to external libs and headers],
[(or in the default path if not specified).]),