aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2014-10-03 14:50:56 -0400
committerMaxim Uvarov <maxim.uvarov@linaro.org>2014-10-08 20:36:58 +0400
commit80421759e6633ca493c5440c31324ce460f850c9 (patch)
tree3c1e85e14fa70dd271b73cbd92824725d6cba5fd /configure.ac
parent7df90a6f64f620daf653c0462a9ddee9ef6f4935 (diff)
Add cunit test for APIs in odp_init.h
Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 46eaec1..a840e5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,28 @@ AC_SUBST(SDK_INSTALL_PATH)
AM_CONDITIONAL([SDK_INSTALL_PATH_], [test "x${SDK_INSTALL_PATH_}" = "x1"])
+
+##########################################################################
+# Enable/disable Unit tests
+##########################################################################
+AC_ARG_ENABLE([cunit],
+ [ --enable-cunit Enable/disable cunit],
+ [if test x$enableval = xyes; then
+ cunit_support=yes
+ fi])
+
+AC_ARG_WITH([cunit-path],
+AC_HELP_STRING([--with-cunit-path=DIR Path to Cunit libs and headers],
+ [(or in the default path if not specified).]),
+[CUNIT_PATH=$withval cunit_support=yes ],[ ])
+
+AS_IF([test x$cunit_support = xyes ], [
+ AC_CHECK_HEADERS([CUnit/Basic.h], [],
+ [AC_MSG_FAILURE(["can't find cunit headers"])])
+])
+AC_SUBST(CUNIT_PATH)
+AM_CONDITIONAL([ODP_CUNIT_ENABLED], [test x$cunit_support = xyes ])
+
##########################################################################
# Enable/disable ODP_DEBUG_PRINT
##########################################################################
@@ -138,6 +160,7 @@ AC_CONFIG_FILES([Makefile
example/timer/Makefile
test/Makefile
test/api_test/Makefile
+ test/cunit/Makefile
pkgconfig/libodp.pc])
AC_SEARCH_LIBS([timer_create],[rt posix4])