aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Milard <christophe.milard@linaro.org>2015-06-10 18:54:23 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-06-11 17:18:55 +0300
commit7cd8a605dc70cc4bbca4ba59c44c662ba5402781 (patch)
tree07f78748ba4d756a93bbb091b5fb614a723678a6 /configure.ac
parented173ed785c69be66339b01e4c10c64279616cce (diff)
validation: changing build order
When tests will be ran from the platform side, they will use platform agnostic tests from the validation side: i.e. -the validation side must be build before the platform test side. And the platform agnostic tests uses ODP. The building order must therefore be as follows: 1) <platform> (i.e. ODP) 2) validation (i.e. common tests) 3) <platform>/test (i.e. the platform specific test setup and tests) Saddly, writing SUBDIRS=platform/@with_platform@ does not work with autotools, which leads to a bit of clutter in configure.ac. Hopefully changed if things move around in the future... Signed-off-by: Christophe Milard <christophe.milard@linaro.org> Reviewed-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Stuart Haslam <stuart.haslam@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5f1cc66..533bd78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,8 @@ AC_ARG_WITH([platform],
])
AC_SUBST([with_platform])
+AC_SUBST([platform_with_platform], ["platform/${with_platform}"])
+AC_SUBST([platform_with_platform_test], ["platform/${with_platform}/test"])
if test "${with_platform}" == "linux-generic";
then
@@ -294,7 +296,6 @@ AC_CONFIG_FILES([Makefile
helper/Makefile
helper/test/Makefile
pkgconfig/libodp.pc
- platform/Makefile
platform/linux-generic/Makefile
scripts/Makefile
test/Makefile