aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Kagstrom <simon.kagstrom@netinsight.net>2015-02-25 17:04:17 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-02-26 14:23:47 +0300
commit25270ef02b18b55e26a1401b7c551c244669fa11 (patch)
tree4e66da9731da6b0df099badcff5a6991097ec8b2 /configure.ac
parentc0251a13eddbfb42212f276a3d18c8e343f38f3b (diff)
test: miscellaneous: Add CPP test
Add conditional test to link and run ODP from a cpp application. Signed-off-by: Simon Kagstrom <simon.kagstrom@netinsight.net> Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-and-tested-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e5c1c56..7d45ece 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,8 @@ AM_SILENT_RULES([yes])
AC_PROG_CC
AM_PROG_CC_C_O
+AC_PROG_CXX
+
AC_PROG_INSTALL
AC_PROG_MAKE_SET
@@ -114,6 +116,20 @@ AC_ARG_ENABLE([test-perf],
AM_CONDITIONAL([test_perf], [test x$test_perf = xyes ])
##########################################################################
+# Enable/disable test-cpp
+##########################################################################
+test_cpp=no
+AC_ARG_ENABLE([test-cpp],
+ [ --enable-test-cpp run basic test aginast cpp],
+ [if test "x$enableval" = "xyes"; then
+ test_cpp=yes
+ else
+ test_cpp=no
+ fi])
+
+AM_CONDITIONAL([test_cpp], [test x$test_cpp = xyes ])
+
+##########################################################################
# Set optional CUnit path
##########################################################################
AC_ARG_WITH([cunit-path],
@@ -228,6 +244,7 @@ ODP_CFLAGS="$ODP_CFLAGS -Wformat-security -Wundef -Wwrite-strings"
# Default include setup
##########################################################################
AM_CFLAGS="$AM_CFLAGS $ODP_CFLAGS"
+AM_CXXFLAGS="-std=c++11"
AC_CONFIG_FILES([Makefile
doc/Makefile
@@ -244,6 +261,7 @@ AC_CONFIG_FILES([Makefile
test/api_test/Makefile
test/performance/Makefile
test/validation/Makefile
+ test/miscellaneous/Makefile
])
AC_SEARCH_LIBS([timer_create],[rt posix4])
@@ -276,6 +294,7 @@ AC_MSG_RESULT([
cc: ${CC}
cppflags: ${CPPFLAGS}
am_cppflags: ${AM_CPPFLAGS}
+ am_cxxflags: ${AM_CXXFLAGS}
cflags: ${CFLAGS}
am_cflags: ${AM_CFLAGS}
ldflags: ${LDFLAGS}
@@ -284,4 +303,5 @@ AC_MSG_RESULT([
cunit: ${cunit_support}
test_vald: ${test_vald}
test_perf: ${test_perf}
+ test_cpp: ${test_cpp}
])