aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorRu Jia <jiaru@ict.ac.cn>2016-06-30 16:15:31 +0800
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-01-12 17:57:41 +0300
commitfd86c7fd19820e21c182e2c0e043331e6aab6282 (patch)
treef3dfc2dc53e5fb03df855642c277854ef98a04c6 /helper/Makefile.am
parent4a58145d0ca4e62ff41b052ed800acee7d0a97e1 (diff)
helper: table: add impl of ip lookup table
This is an implementation of the 16,8,8 ip lookup (longest prefix matching) algorithm. The key of the table is 32-bit IPv4 address. Signed-off-by: Ru Jia <jiaru@ict.ac.cn> Reviewed-and-tested-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index f7dd32468..9d0036de0 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -30,7 +30,8 @@ noinst_HEADERS = \
$(srcdir)/odph_hashtable.h \
$(srcdir)/odph_lineartable.h \
$(srcdir)/odph_cuckootable.h \
- $(srcdir)/odph_list_internal.h
+ $(srcdir)/odph_list_internal.h \
+ $(srcdir)/odph_iplookuptable.h
__LIB__libodphelper_linux_la_SOURCES = \
eth.c \
@@ -39,6 +40,7 @@ __LIB__libodphelper_linux_la_SOURCES = \
linux.c \
hashtable.c \
lineartable.c \
- cuckootable.c
+ cuckootable.c \
+ iplookuptable.c
lib_LTLIBRARIES = $(LIB)/libodphelper-linux.la