aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorBill Fischofer <bill.fischofer@linaro.org>2016-08-30 20:37:25 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-09-07 16:07:37 +0300
commitda7a72e86db0cf83f7b391d8516f9b7504f4e27a (patch)
tree62a0cb3bca2811fa22c3b7125ae507286c71c004 /helper/Makefile.am
parenta7f5589f81864c71faf18c3d2c3636320cecb1c6 (diff)
linux-generic: configure: add conditional shared library support
Add support for the --enable-shared=[yes|no] configure options. --enable-shared=yes is the default and results in suppressing the use of inlines for ODP API functions to enhance ABI compatibility at potentially some performance cost. When --enable-shared=no is specified, inlines are allowed to boost performance at the possible loss of ABI compatibility. This patch addresses Bug https://bugs.linaro.org/show_bug.cgi?id=2490 Note: This patch is a port of the corresponding enhancements made to odp-dpdk with a few changes, mainly that inlines are now part of the odp/api/plat directory, and all ODP APIs are now treated uniformly with regard to whether inlining is permitted. Suggested-by: Zoltan Kiss <zoltan.kiss@linaro.org> Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> Reviewed-by: Balakrishna Garapati <balakrishna.garapati@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index a82a11aa5..b6e6a1dc4 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -7,6 +7,7 @@ LIB = $(top_builddir)/lib
AM_CFLAGS = -I$(srcdir)/include
AM_CFLAGS += -I$(top_srcdir)/platform/@with_platform@/include
AM_CFLAGS += -I$(top_srcdir)/include
+AM_CFLAGS += -I$(top_builddir)/platform/@with_platform@/include
AM_LDFLAGS += -version-number '$(ODPHELPER_LIBSO_VERSION)'