aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorRu Jia <jiaru@ict.ac.cn>2016-06-13 14:42:13 +0800
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-01-12 17:57:41 +0300
commitb2d4275c2df6a7fcd9796fafed74b59292cee26e (patch)
tree39a2fa4da73d2c6fe7b31446465dc58f5ce3d930 /helper/Makefile.am
parent5ffbdadc12513adb3e8847692d51963cab223084 (diff)
helper: table: add impl of cuckoo hash table
Signed-off-by: Ru Jia <jiaru@ict.ac.cn> Reviewed-and-tested-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index d09d9008e..f7dd32468 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -29,6 +29,7 @@ noinst_HEADERS = \
$(srcdir)/odph_debug.h \
$(srcdir)/odph_hashtable.h \
$(srcdir)/odph_lineartable.h \
+ $(srcdir)/odph_cuckootable.h \
$(srcdir)/odph_list_internal.h
__LIB__libodphelper_linux_la_SOURCES = \
@@ -37,6 +38,7 @@ __LIB__libodphelper_linux_la_SOURCES = \
chksum.c \
linux.c \
hashtable.c \
- lineartable.c
+ lineartable.c \
+ cuckootable.c
lib_LTLIBRARIES = $(LIB)/libodphelper-linux.la