aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@linaro.org>2017-02-03 13:23:59 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-02-16 23:30:27 +0300
commitaf5205809e3921ea0c4db5771ea1da5d2f0eaaf5 (patch)
tree792e274bcd065b57a31c67ce455f16c96640ee4d /helper/Makefile.am
parent32b94edb4961a3ac1a2e5c90f65ee3f118852151 (diff)
helper: linux: renamed threads_extn to linux helpers
There's no platform specific helpers. Helpers may depend on Linux and make it easier to do common series of Linux system calls. These kind of helpers are grouped into helper/linux directory. Use --enable-helper-linux configuration option to enable support for Linux helpers. Signed-off-by: Petri Savolainen <petri.savolainen@linaro.org> Reviewed-by: Mike Holmes <mike.holmes@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 6b65eb1c3..5757c7c81 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -31,16 +31,18 @@ helperinclude_HEADERS = \
$(srcdir)/include/odp/helper/threads.h \
$(srcdir)/include/odp/helper/udp.h
-if helper_extn
-helperinclude_HEADERS += \
- $(srcdir)/include/odp/helper/platform/@with_helper_platform@/threads_extn.h
+if helper_linux
+helperlinuxincludedir = $(includedir)/odp/helper/linux
+helperlinuxinclude_HEADERS = \
+ $(srcdir)/include/odp/helper/linux/pthread.h \
+ $(srcdir)/include/odp/helper/linux/process.h
endif
noinst_HEADERS = \
$(srcdir)/odph_debug.h \
$(srcdir)/odph_list_internal.h
-__LIB__libodphelper_@with_platform@_la_SOURCES = \
+__LIB__libodphelper_la_SOURCES = \
eth.c \
ip.c \
chksum.c \
@@ -50,9 +52,9 @@ __LIB__libodphelper_@with_platform@_la_SOURCES = \
iplookuptable.c \
threads.c
-if helper_extn
-__LIB__libodphelper_@with_platform@_la_SOURCES += \
- platform/@with_helper_platform@/thread.c
+if helper_linux
+__LIB__libodphelper_la_SOURCES += \
+ linux/thread.c
endif
-lib_LTLIBRARIES = $(LIB)/libodphelper-@with_platform@.la
+lib_LTLIBRARIES = $(LIB)/libodphelper.la