aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMaxim Uvarov <maxim.uvarov@linaro.org>2015-12-01 16:27:31 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-12-03 17:57:47 +0300
commit28a6ef9c0b4b4cce3e72fc27dbe3040683215b80 (patch)
treeb24409e7f943607b378046c07398f971ed427669 /helper/Makefile.am
parent89701399735b08f8a8c90574c85a7589e51d2cdf (diff)
helper: strong types support
Add strong types support for helpers the same as we have for linux-generic. That should be useful for complex algorithms where type check is needed. Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org> Tested-by: Ivan Khoronzhuk <ivan.khoronzhuk@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index bed8683d2..1906ae285 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -15,6 +15,7 @@ helperinclude_HEADERS = \
$(srcdir)/include/odp/helper/icmp.h\
$(srcdir)/include/odp/helper/ip.h\
$(srcdir)/include/odp/helper/ipsec.h\
+ $(srcdir)/include/odp/helper/strong_types.h\
$(srcdir)/include/odp/helper/tcp.h\
$(srcdir)/include/odp/helper/table.h\
$(srcdir)/include/odp/helper/udp.h