aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorBarry Spinney <spinney@mellanox.com>2016-04-28 22:35:41 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2016-04-29 11:47:51 +0300
commit0e1645087dea2c7744b2384e8c4d790d79e3125e (patch)
tree286e7c4bd3112df6e4175c2c242321de5842b641 /helper/Makefile.am
parent166859a5380cd156f65a2143216d04e17399b6dc (diff)
helper: add a more complete and correct checksum implementation
This patch adds a file called chksum.c which implements a complete TCP/UDP over either IPv4 or IPV6 checksum generation / verification capability. In addition it can deal with any form of packet segmentation including tiny segments, segments not aligned to a 2 byte boundary, etc. Signed-off-by: Barry Spinney <spinney@mellanox.com> Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 8a86eb719..aa58e8c95 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -32,6 +32,7 @@ noinst_HEADERS = \
__LIB__libodphelper_linux_la_SOURCES = \
eth.c \
ip.c \
+ chksum.c \
linux.c \
hashtable.c \
lineartable.c