aboutsummaryrefslogtreecommitdiff
path: root/test/common_plat/validation/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/common_plat/validation/api/Makefile.am')
-rw-r--r--test/common_plat/validation/api/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/common_plat/validation/api/Makefile.am b/test/common_plat/validation/api/Makefile.am
new file mode 100644
index 000000000..e2d30a673
--- /dev/null
+++ b/test/common_plat/validation/api/Makefile.am
@@ -0,0 +1,28 @@
+ODP_MODULES = atomic \
+ barrier \
+ buffer \
+ classification \
+ cpumask \
+ crypto \
+ errno \
+ hash \
+ init \
+ lock \
+ queue \
+ packet \
+ pktio \
+ pool \
+ random \
+ scheduler \
+ std_clib \
+ thread \
+ time \
+ timer \
+ traffic_mngr \
+ shmem \
+ system
+
+SUBDIRS = $(ODP_MODULES)
+
+#The tests will need to retain the deprecated test implementation
+AM_CFLAGS += -Wno-deprecated-declarations