aboutsummaryrefslogtreecommitdiff
path: root/test/common_plat/performance/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/common_plat/performance/Makefile.am')
-rw-r--r--test/common_plat/performance/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/test/common_plat/performance/Makefile.am b/test/common_plat/performance/Makefile.am
new file mode 100644
index 000000000..d23bb3e51
--- /dev/null
+++ b/test/common_plat/performance/Makefile.am
@@ -0,0 +1,33 @@
+include $(top_srcdir)/test/Makefile.inc
+
+TESTS_ENVIRONMENT += TEST_DIR=${builddir}
+
+EXECUTABLES = odp_crypto$(EXEEXT) odp_pktio_perf$(EXEEXT)
+
+COMPILE_ONLY = odp_l2fwd$(EXEEXT) \
+ odp_scheduling$(EXEEXT)
+
+TESTSCRIPTS = odp_l2fwd_run.sh \
+ odp_scheduling_run.sh
+
+TEST_EXTENSIONS = .sh
+
+if test_perf
+TESTS = $(EXECUTABLES) $(TESTSCRIPTS)
+endif
+
+bin_PROGRAMS = $(EXECUTABLES) $(COMPILE_ONLY)
+
+odp_crypto_LDFLAGS = $(AM_LDFLAGS) -static
+odp_crypto_CFLAGS = $(AM_CFLAGS) -I${top_srcdir}/test
+odp_scheduling_LDFLAGS = $(AM_LDFLAGS) -static
+odp_scheduling_CFLAGS = $(AM_CFLAGS) -I${top_srcdir}/test
+
+noinst_HEADERS = \
+ $(top_srcdir)/test/test_debug.h
+
+dist_odp_crypto_SOURCES = odp_crypto.c
+dist_odp_scheduling_SOURCES = odp_scheduling.c
+dist_odp_pktio_perf_SOURCES = odp_pktio_perf.c
+
+EXTRA_DIST = $(TESTSCRIPTS)