aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b12001f25..465304d9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odpapi_generation_version], [1])
-m4_define([odpapi_major_version], [23])
-m4_define([odpapi_minor_version], [5])
+m4_define([odpapi_major_version], [24])
+m4_define([odpapi_minor_version], [0])
m4_define([odpapi_point_version], [0])
m4_define([odpapi_version],
[odpapi_generation_version.odpapi_major_version.odpapi_minor_version.odpapi_point_version])
@@ -136,7 +136,7 @@ ODP_CHECK_CFLAG([-Wno-error=address-of-packed-member])
# GCC 10 sometimes gets confused about object sizes and gives bogus warnings.
# Make the affected warnings generate only warnings, not errors.
AS_IF([test "$GCC" == yes],
- AS_IF([test `$CC -dumpversion` -ge 10],
+ AS_IF([test `$CC -dumpversion | cut -d '.' -f 1` -ge 10],
ODP_CHECK_CFLAG([-Wno-error=array-bounds])
ODP_CHECK_CFLAG([-Wno-error=stringop-overflow])
)
@@ -295,6 +295,7 @@ AC_DEFINE_UNQUOTED([_ODP_IMPLEMENTATION_NAME], ["$ODP_IMPLEMENTATION_NAME"],
[Define to the name of the implementation])
AM_CONDITIONAL([ODP_USE_CONFIG], [test "x$odp_use_config" = "xtrue"])
+AC_SUBST([ODP_LIB_NAME])
##########################################################################
# Build examples/tests dynamically
@@ -456,6 +457,7 @@ AC_OUTPUT
AC_MSG_RESULT([
$PACKAGE $VERSION
+ ODP Library name: ${ODP_LIB_NAME}
ODP Library version: ${ODP_LIBSO_VERSION}
Helper Library version: ${ODPHELPER_LIBSO_VERSION}
@@ -499,6 +501,7 @@ AC_MSG_RESULT([
test_example: ${test_example}
user_guides: ${user_guides}
pcapng: ${have_pcapng}
+ default_config_path: ${default_config_path}
])
AS_IF([test "${with_openssl}" = "no"],