aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-09-29 14:26:48 +0300
committerMatias Elo <matias.elo@nokia.com>2021-10-01 10:20:36 +0300
commitec78e5305c387cef47be7479d2b9f85482e20b40 (patch)
tree259731819a0291c0c23052c1a5a44e4f873e9e0f /configure.ac
parenta369bcd19a32cae230b9428e29c008dbd785c681 (diff)
api: increment ODP API version to 1.32.0.0
Increment API version number to reflect the following changes: Backward incompatible: * ipsec: added destination queue capabilities odp_ipsec_capability_t.queue_type_sched and odp_ipsec_capability_t.queue_type_plain * ipsec: modified specification to not promise the original packet back after all error cases Backward compatible: - ipsec: added original ESP/AH packet length into IPsec packet result (odp_ipsec_packet_result_t.orig_ip_len) - packet: added odp_packet_reass_info() function for reading completed reassembly details - std: moved all contents of support and feature modules into ODP Std module Helper library (1.2.0): Backward incompatible: - cli: replaced odph_cli_start() function with odph_cli_run(), which doesn't automatically create a separate thread for running the CLI server. - linux: deprecated odph_odpthread_t and odph_odpthread_params_t types - linux: added odph_thread_param_init() function for initializing thread parameters - linux: added odph_thread_common_param_init() function for initializing thread common parameters Backward compatible: - cli: added odph_cli_param_t.hostname parameter for providing a custom CLI prompt hostname - cli: added odph_cli_log_va() function for user defined CLI commands - linux: added odph_thread_param_t.stack_size parameter for configuring minimum thread stack size - linux: added odph_thread_common_param_t.sync_timeout parameter for configuring synchronized thread creation timeout Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e1f050a81..e2a227cd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odpapi_generation_version], [1])
-m4_define([odpapi_major_version], [31])
+m4_define([odpapi_major_version], [32])
m4_define([odpapi_minor_version], [0])
m4_define([odpapi_point_version], [0])
m4_define([odpapi_version],
@@ -21,8 +21,8 @@ AC_SUBST(ODP_VERSION_API_MINOR)
# Helper library version
##########################################################################
m4_define([odph_version_generation], [1])
-m4_define([odph_version_major], [1])
-m4_define([odph_version_minor], [1])
+m4_define([odph_version_major], [2])
+m4_define([odph_version_minor], [0])
m4_define([odph_version],
[odph_version_generation.odph_version_major.odph_version_minor])