aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2023-06-12 14:21:58 +0300
committerMatias Elo <matias.elo@nokia.com>2023-12-21 15:53:15 +0200
commitbcc3a8c36f39b13d34e9de14e9962cbc67229dff (patch)
treefd80d1e3aad49c9a7bb9560ccae17f99206edfdc /configure.ac
parent2ecf3e3fd8064bafdbba8dfa8cd7c527241e492b (diff)
configure: add -Wno-error=stringop-overflow also to CXXFLAGS
Also c++ programs need -Wno-error=stringop-overflow flag, in order to avoid errors during linking, when using LTO. Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Janne Peltonen <janne.peltonen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8459553b4..18b3861d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,6 +120,7 @@ AS_IF([test "$GCC" == yes],
AS_IF([test `$CC -dumpversion | cut -d '.' -f 1` -ge 10],
ODP_CHECK_CFLAG([-Wno-error=array-bounds])
ODP_CHECK_CFLAG([-Wno-error=stringop-overflow])
+ ODP_CHECK_CXXFLAG([-Wno-error=stringop-overflow])
)
)