aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2017-12-31 04:11:34 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2018-01-22 13:08:13 +0300
commit988ae5930a9db1ceb88e46a84a116e67b0108307 (patch)
tree10968f5eedad1357ea3d083510c42595f4bcf91f /configure.ac
parent5a4502fc6bc53e6503169da3028f456b64811a0b (diff)
build: provide an option to link examples dynamically
Distributions won't like statically-linked binaries. Provide configure switch to link examples and tests dynamically. Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bogdan Pricope <bogdan.pricope@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c8799f1e..56a422b4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,6 +183,16 @@ AC_DEFINE_UNQUOTED([IMPLEMENTATION_NAME], ["$IMPLEMENTATION_NAME"],
[Define to the name of the implementation])
##########################################################################
+# Build examples/tests dynamically
+##########################################################################
+AC_ARG_ENABLE([static-applications],
+ [AS_HELP_STRING([--disable-static-applications],
+ [disable static linking of examples and tests]
+ [ with ODP])], [],
+ [enable_static_applications=yes])
+AM_CONDITIONAL([STATIC_APPS], [test "x$enable_static_applications" != "xno"])
+
+##########################################################################
# Include m4 files
##########################################################################
m4_include([./doc/m4/configure.m4])
@@ -393,6 +403,7 @@ AC_MSG_RESULT([
Deprecated APIs: ${deprecated}
debug: ${enable_debug}
cunit: ${cunit_support}
+ static tests linkage: ${enable_static_applications}
test_vald: ${test_vald}
test_perf: ${test_perf}
test_perf_proc: ${test_perf_proc}