aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStanislaw Kardach <skardach@marvell.com>2020-09-03 15:34:33 +0200
committerMatias Elo <matias.elo@nokia.com>2020-09-07 13:38:00 +0300
commit8d3c458848294495a1e7a45846d659a384ab69e3 (patch)
treed56d5a8b537041bfd444a7d76db3ef5f956b84fe /configure.ac
parent4394b1b1f33159bad4f71bc46fd405a6a948c96a (diff)
build: re-format autoconf argument defaults
Make sure that all autoconf arguments defined by ODP use default value description similar to built-in arguments. That is: [default=<value>]. Also make sure that all arguments use AS_HELP_STRING for uniform text formatting. Signed-off-by: Stanislaw Kardach <skardach@marvell.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 24 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index c58407191..4de488a25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,7 +166,7 @@ AX_VALGRIND_CHECK
##########################################################################
AC_ARG_WITH([archincludedir],
[AS_HELP_STRING([--with-archincludedir=DIR],
- [directory to hold arch-specific headers (${includedir})])],
+ [directory to hold arch-specific headers [default=INCLUDEDIR]])],
[archincludedir=$with_archincludedir],
[archincludedir="${includedir}"])
AC_SUBST([archincludedir])
@@ -201,7 +201,8 @@ AC_SUBST([ARCH_ABI])
AC_ARG_ENABLE([host-optimization],
[AS_HELP_STRING([--disable-host-optimization],
- [disables using host-specific ARCH and ABI files])],
+ [disables using host-specific ARCH and ABI files]
+ [[default=enabled]])],
[], [enable_host_optimization=yes])
if test "x$enable_host_optimization" = "xno" ; then
ARCH_DIR=default
@@ -234,7 +235,8 @@ ODP_ABI_COMPAT=1
abi_compat=yes
AC_ARG_ENABLE([abi-compat],
[AS_HELP_STRING([--disable-abi-compat],
- [disables ABI compatible mode, enables inline code in header files])],
+ [disables ABI compatible mode, enables inline code in header files]
+ [[default=enabled]])],
[if test "x$enableval" = "xno"; then
ODP_ABI_COMPAT=0
abi_compat=no
@@ -259,7 +261,8 @@ AM_CONDITIONAL(ODP_ABI_COMPAT, [test "x$ODP_ABI_COMPAT" = "x1"])
lto_enabled=no
AC_ARG_ENABLE([lto],
[AS_HELP_STRING([--enable-lto],
- [Enable Link Time Optimization (LTO) in compiler and linker])],
+ [Enable Link Time Optimization (LTO) in compiler and linker]
+ [[default=disabled]])],
[if test "x$enableval" = "xyes"; then
lto_enabled=yes
# Fat LTO object file contains GIMPLE bytecodes and the usual
@@ -277,7 +280,7 @@ ODP_CFLAGS="$ODP_CFLAGS $ODP_LTO_FLAGS"
AC_ARG_ENABLE([static-applications],
[AS_HELP_STRING([--disable-static-applications],
[disable static linking of examples and tests]
- [ with ODP])], [],
+ [with ODP [default=enabled]])], [],
[enable_static_applications=yes])
AS_IF([test "x$enable_static" != "xno" -a "x$enable_static_applications" != "xno"],
[enable_static_applications=yes], [enable_static_applications=no])
@@ -295,7 +298,8 @@ fi
##########################################################################
AC_ARG_WITH([openssl],
[AS_HELP_STRING([--without-openssl],
- [compile without OpenSSL (may result in disabled crypto and random support)])],
+ [compile without OpenSSL (may result in disabled crypto and random support)]
+ [[default=with]])],
[],
[with_openssl=yes])
AS_IF([test "$with_openssl" != "no"],
@@ -314,7 +318,8 @@ m4_include([./test/m4/configure.m4])
# Set the install directory for test binaries/scripts
##########################################################################
AC_ARG_WITH([testdir],
- [AS_HELP_STRING([--with-testdir=DIR], [installation directory for tests])],
+ [AS_HELP_STRING([--with-testdir[=DIR]],
+ [installation directory for tests [default=none]])],
[testdir=$withval],
[testdir=no])
AS_IF([test "x$testdir" = "xyes"], [testdir=$libdir/odp/tests],
@@ -343,8 +348,9 @@ AM_CONDITIONAL([ARCH_IS_X86_64], [test "x${ARCH_ABI}" = "xx86_64-linux"])
##########################################################################
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
- [include additional debugging code ]
- [(set to 'full' to enable all --enable-*-debug-* options)])],
+ [include additional debugging code.]
+ [Set to 'full' to enable all --enable-*-debug-* options]
+ [[default=disabled]])],
[], [enable_debug=no])
AS_IF([test "x$enable_debug" != "xno"], [ODP_DEBUG=1],
@@ -353,7 +359,8 @@ AC_DEFINE_UNQUOTED([ODP_DEBUG], [$ODP_DEBUG],
[Define to 1 to include additional debug code])
AC_ARG_ENABLE([helper-debug],
- [AS_HELP_STRING([--enable-helper-debug], [helpers include additional debugging code])],
+ [AS_HELP_STRING([--enable-helper-debug],
+ [helpers include additional debugging code [default=disabled]])],
[], [AS_IF([test "x$enable_debug" = "xfull"], [enable_helper_debug=yes],
[enable_helper_debug=no])])
AS_IF([test "x$enable_helper_debug" != "xno"], [ODPH_DEBUG=1], [ODPH_DEBUG=0])
@@ -364,7 +371,8 @@ AC_DEFINE_UNQUOTED([ODPH_DEBUG], [$ODPH_DEBUG],
# Enable/disable ODP_DEBUG_PRINT
##########################################################################
AC_ARG_ENABLE([debug-print],
- [AS_HELP_STRING([--enable-debug-print], [display debugging information])],
+ [AS_HELP_STRING([--enable-debug-print],
+ [display debugging information [default=disabled]])],
[], [AS_IF([test "x$enable_debug" = "xfull"], [enable_debug_print=yes],
[enable_debug_print=no])])
AS_IF([test "x$enable_debug_print" != "xno"], [ODP_DEBUG_PRINT=1],
@@ -373,7 +381,8 @@ AC_DEFINE_UNQUOTED([ODP_DEBUG_PRINT], [$ODP_DEBUG_PRINT],
[Define to 1 to display debug information])
AC_ARG_ENABLE([helper-debug-print],
- [AS_HELP_STRING([--enable-helper-debug-print], [display helper debugging information])],
+ [AS_HELP_STRING([--enable-helper-debug-print],
+ [display helper debugging information [default=disabled]])],
[], [AS_IF([test "x$enable_debug" = "xfull"], [enable_helper_debug_print=yes],
[enable_helper_debug_print=no])])
AS_IF([test "x$enable_helper_debug_print" != "xno"], [ODPH_DEBUG_PRINT=1],
@@ -390,7 +399,8 @@ ODPH_DEBUG=${ODPH_DEBUG}, ODPH_DEBUG_PRINT=${ODPH_DEBUG_PRINT}"
ODP_DEPRECATED_API=0
deprecated=no
AC_ARG_ENABLE([deprecated],
- [ --enable-deprecated enable deprecated API definitions],
+ [AS_HELP_STRING([--enable-deprecated],
+ [enable deprecated API definitions [default=disabled]])],
[if test "x$enableval" = "xyes"; then
ODP_DEPRECATED_API=1
deprecated=yes
@@ -402,7 +412,7 @@ AC_SUBST(ODP_DEPRECATED_API)
##########################################################################
AC_ARG_WITH([platform],
[AS_HELP_STRING([--with-platform=platform],
- [select platform to be used, default linux-generic])],
+ [select platform to be used [default=linux-generic]])],
[],
[with_platform=linux-generic
])