aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2021-01-15 16:26:33 +0200
committerPetri Savolainen <petri.savolainen@nokia.com>2021-02-23 11:01:07 +0200
commit84b6587531ea50a9de473587af52cdf39f7e9dd9 (patch)
treed3bc629718d344f786aafe42a39f8a4a6c41c720 /configure.ac
parentee9a6a9a9e46aac337b8b105ef5d2c7e754ce3c0 (diff)
helper: add CLI helper API and implementation
CLI helper API allows starting and stopping ODP CLI server, which may be connected to using a telnet client. CLI commands may be used to get information from an ODP instance, for debugging purposes. This implementation depends on libcli. If libcli is not available, CLI helper is automatically excluded. Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2761190a3..83b25b4eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,6 +332,7 @@ AM_CONDITIONAL([HAVE_DOXYGEN], [test "x${DOXYGEN}" = "xdoxygen"])
AM_CONDITIONAL([user_guide], [test "x${user_guides}" = "xyes" ])
AM_CONDITIONAL([HAVE_MSCGEN], [test "x${MSCGEN}" = "xmscgen"])
AM_CONDITIONAL([helper_linux], [test x$helper_linux = xyes ])
+AM_CONDITIONAL([helper_cli], [test x$helper_cli = xyes ])
AM_CONDITIONAL([ARCH_IS_ARM], [test "x${ARCH_DIR}" = "xarm"])
AM_CONDITIONAL([ARCH_IS_AARCH64], [test "x${ARCH_DIR}" = "xaarch64"])
AM_CONDITIONAL([ARCH_IS_DEFAULT], [test "x${ARCH_DIR}" = "xdefault"])
@@ -479,6 +480,7 @@ AC_MSG_RESULT([
ARCH_ABI ${ARCH_ABI}
with_platform: ${with_platform}
helper_linux: ${helper_linux}
+ helper_cli: ${helper_cli}
prefix: ${prefix}
sysconfdir: ${sysconfdir}
libdir: ${libdir}