aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-04-20 09:50:45 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2021-04-23 09:24:26 +0300
commit742a6b8ef68d80b898a13bed42a4afcb4d8311cf (patch)
treeffa2fbe469a08c92dc0649ef981107278c7c9876 /configure.ac
parenta91e02d6a217bbcfbb1e971894e7376f3f956b14 (diff)
configure: change abi compatibility default value to disabled
Disable ABI compatibility by default. This way the ODP implementation will offer the best available performance without the user having to change the default configuration. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index fdde95e70..d15883049 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,27 +226,28 @@ AC_SUBST(PKGCONFIG_VERSION)
##########################################################################
# Enable/disable ABI compatible build
##########################################################################
-ODP_ABI_COMPAT=1
-abi_compat=yes
+ODP_ABI_COMPAT=0
+abi_compat=no
AC_ARG_ENABLE([abi-compat],
- [AS_HELP_STRING([--disable-abi-compat],
- [disables ABI compatible mode, enables inline code in header files]
- [[default=enabled]])],
- [if test "x$enableval" = "xno"; then
- ODP_ABI_COMPAT=0
- abi_compat=no
-
- #if there is no ABI compatibility the .so numbers are meaningless
+ [AS_HELP_STRING([--enable-abi-compat],
+ [enables ABI compatible mode, disables inline code in header files]
+ [[default=disabled]])],
+ [if test "x$enableval" = "xyes"; then
+ ODP_ABI_COMPAT=1
+ abi_compat=yes
+ fi])
+if test "x$abi_compat" = "xno" ; then
+ # If there is no ABI compatibility the .so numbers are meaningless
ODP_LIBSO_VERSION=0:0:0
- # do not use -march=native with clang (due to possible failures on
+ # Do not use -march=native with clang (due to possible failures on
# clang optimizations).
$CC --version | grep -q clang
if test $? -ne 0; then
ODP_CHECK_CFLAG([-march=native])
fi
- fi])
+fi
AM_CONDITIONAL(ODP_ABI_COMPAT, [test "x$ODP_ABI_COMPAT" = "x1"])
##########################################################################