aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-07-09 15:05:39 +0300
committerMatias Elo <matias.elo@nokia.com>2021-07-21 15:34:47 +0300
commit6f0ff9d9ca6a2e1e9e81aa068d86deda79046888 (patch)
treee4f701ac20c9b908327f85177e2d802a75272917 /configure.ac
parentf10cb64e90960613dbb21365e8249704ca11e1fd (diff)
api: increment ODP API version to 1.31.0.0
Increment API version number to reflect the following changes: Backward incompatible: - traffic manager: added new feature capabilities and an egress specific capability function odp_tm_egress_capabilities() - traffic manager: deprecated odp_tm_capabilities() function which is replaced by odp_tm_egress_capabilities() - traffic manager: added maximum number of schedulers per TM node capability - traffic manager: added support for non-global packet priority mode Backward compatible: - classifier: added odp_cls_queue_stats() for reading queue specific statistics counters - ipsec: added ICV length into SA configuration parameters - packet: added odp_packet_disassemble(), odp_packet_reassemble(), and other new functions for packets allocated from external memory pools - packet: added per packet protocol statistics functions - packet_io: added packet output configuration option for enabling packet protocol statistics updates - pool: added new concept of external memory pools, which are populated with application provided memory - pool: added new odp_pool_type_t enumeration - proto_stats: added new generic protocol statistics framework - traffic manager: increased scheduling weight parameter size (uint8_t to uint32_t) - traffic manager: added odp_tm_queue_stats() for reading queue specific statistics counters - traffic manager: added odp_tm_enq_multi() function for enqueueing multiple packets at a time - traffic manager: added odp_tm_queue_params_t.ordered_enqueue option which can be used to control if ordering is enabled Helper library: - ipsec: added odph_ipsec_auth_icv_len_default() function for returning the default ICV length of an algorithm - ipsec: added support for AES-CMAC into odph_ipsec_alg_check() - ipsec: added default ICV length check into odph_ipsec_alg_check() Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Janne Peltonen <janne.peltonen@nokia.com> Reviewed-by: Jerin Jacob <jerinj@marvell.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 725e7a6ea..e1f050a81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odpapi_generation_version], [1])
-m4_define([odpapi_major_version], [30])
-m4_define([odpapi_minor_version], [1])
+m4_define([odpapi_major_version], [31])
+m4_define([odpapi_minor_version], [0])
m4_define([odpapi_point_version], [0])
m4_define([odpapi_version],
[odpapi_generation_version.odpapi_major_version.odpapi_minor_version.odpapi_point_version])
@@ -22,7 +22,7 @@ AC_SUBST(ODP_VERSION_API_MINOR)
##########################################################################
m4_define([odph_version_generation], [1])
m4_define([odph_version_major], [1])
-m4_define([odph_version_minor], [0])
+m4_define([odph_version_minor], [1])
m4_define([odph_version],
[odph_version_generation.odph_version_major.odph_version_minor])