aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2021-10-01 18:12:09 +0300
committerPetri Savolainen <petri.savolainen@nokia.com>2021-10-12 17:06:16 +0300
commit69f27643ec2287875048314d7975f0de4bcbbfa4 (patch)
treeae520940ccb286655d631ef18fcef5d0626dbb18 /configure.ac
parent29ff9cd79290aa6eaf74c8fc957cde8aec84f9af (diff)
configure.ac: move project to C standard revision 11
Some C11 features (e.g. anonymous structures and unions) have been already used by the project. Move from C99 to C11 to be standard compliant and enable usage of new features. Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c05cb4914..9a950a115 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,7 +172,7 @@ AS_IF([test "$GCC" == yes],
)
)
-ODP_CFLAGS="$ODP_CFLAGS -std=c99"
+ODP_CFLAGS="$ODP_CFLAGS -std=c11"
ODP_CXXFLAGS="$ODP_CXXFLAGS -std=c++11"
# Extra flags for example to suppress certain warning types