aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2018-02-09 03:01:05 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2018-02-19 14:49:58 +0300
commit34dcdce23b1851f910aef53c4f17f3491f95183c (patch)
tree963010409032f5338c28173f7a53927d6a114b93 /configure.ac
parent7b98d4d5018461db83c3feef696b4470674844de (diff)
configure: add flag to build for host=default
Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 17 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index dd82b66ec..799d0b7b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,14 +164,6 @@ AS_CASE([$host],
AC_SUBST([ARCH_DIR])
##########################################################################
-# Warn on the defaults if arch is undefined
-##########################################################################
-if test "${ARCH_DIR}" = "default";
-then
- AC_MSG_WARN([ARCH_DIR is undefined, please add your ARCH_DIR based on host=${host}])
-fi
-
-##########################################################################
# Architecture for ABI support
##########################################################################
AS_CASE([$host],
@@ -185,6 +177,23 @@ AS_CASE([$host],
)
AC_SUBST([ARCH_ABI])
+AC_ARG_ENABLE([host-optimization],
+ [AS_HELP_STRING([--disable-host-optimization],
+ [disables using host-specific ARCH and ABI files])],
+ [], [enable_host_optimization=yes])
+if test "x$enable_host_optimization" = "xno" ; then
+ ARCH_DIR=default
+ ARCH_ABI=default-linux
+fi
+
+##########################################################################
+# Warn on the defaults if arch is undefined
+##########################################################################
+if test "${ARCH_DIR}" = "default";
+then
+ AC_MSG_WARN([ARCH_DIR is undefined, please add your ARCH_DIR based on host=${host}])
+fi
+
if test "${ARCH_ABI}" = "default-linux";
then
AC_MSG_WARN([ARCH_ABI is undefined, please add your ARCH_ABI based on host=${host}])