aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2023-02-07 15:35:10 +0200
committerMatias Elo <matias.elo@nokia.com>2023-02-13 17:01:12 +0200
commit30930db550a640df1a25847c7623e5ecfe670b9b (patch)
tree9f80254485000241cad2654c01a0b081b43b2d75 /configure.ac
parent32a684b42a99d55c9b2840ac12911e1bd71dded6 (diff)
api: increment ODP API version to 1.40.0
Increment API version number to reflect the following changes: Backward incompatible: - packet: specify which packet metadata flags cannot be set simultaneously using odp_packet_has_XX_set() functions - timer: use ODP_DEPRECATE() macro for odp_timer_set_abs() and odp_timer_set_rel() functions - timer: deprecate old timer pool clock sources ODP_CLOCK_CPU and ODP_CLOCK_EXT - timer: deprecate old timer set return values ODP_TIMER_TOOEARLY, ODP_TIMER_TOOLATE, and ODP_TIMER_NOEVENT Backward compatible: - crypto: add new operation type session parameter odp_crypto_session_param_t.op_type - crypto: add ODP_CRYPTO_OP_TYPE_BASIC operation type - crypto: add ODP_CRYPTO_OP_TYPE_OOP operation type - crypto: clarify odp_crypto_op() documentation regarding packet data and metadata copy - crypto: require that odp_crypto_result() is called before accessing packet data of asynchronously processed packets in non-legacy modes - crypto: fix EIA2 IV length in API documentation - packet: clarify odp_packet_has_vlan() and odp_packet_has_vlan_qinq() specifications Removed deprecated APIs: - crypto: per-session IV configuration - pktio: in_unknown_protos field from odp_pktio_stats_t - pktio: odp_pktin_ts_res() function - pktio: odp_pktin_ts_from_ns() function - shm: ODP_SHM_SW_ONLY define - tm: odp_tm_capabilities() function - tm: commit_bps field from odp_tm_shaper_params_t - tm: peak_bps field from odp_tm_shaper_params_t Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 43446c4f3..d496438a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_PREREQ([2.5])
# ODP API version
##########################################################################
m4_define([odp_version_generation], [1])
-m4_define([odp_version_major], [39])
+m4_define([odp_version_major], [40])
m4_define([odp_version_minor], [0])
m4_define([odp_version_patch], [0])