aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBill Fischofer <bill.fischofer@linaro.org>2018-07-16 17:55:24 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2018-07-18 17:50:45 +0300
commit24201040f2a8e66f11359f29b283831db8550c84 (patch)
treee33b6663b88283cd8e0fa78db6f0bb8c98f349db /configure.ac
parent55b8ccb80bee2eaf7932a5bbb7963544d8fc906b (diff)
configure: add warning about --without-openssl implications
ODP now supports the --without-openssl configure option to not use OpenSSL as part of building odp-linux. However, omitting OpenSSL will make strong cryptographic support unavailable. Display the OpenSSL inclusion status as part of configure output and include a warning to be sure the user understands this implication of omitting this support. Signed-off-by: Bill Fischofer <bill.fischofer@linaro.org> Reviewed-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0eacac323..c07b2c9b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,6 +381,7 @@ AC_MSG_RESULT([
includedir: ${includedir}
testdir: ${testdir}
WITH_ARCH: ${WITH_ARCH}
+ with_openssl: ${with_openssl}
cc: ${CC}
cc version: ${CC_VERSION}
@@ -405,3 +406,7 @@ AC_MSG_RESULT([
user_guides: ${user_guides}
pcapng: ${have_pcapng}
])
+
+AS_IF([test "${with_openssl}" = "no"],
+ [AC_MSG_WARN([Strong cryptography is not available without OpenSSL])]
+ )