aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatias Elo <matias.elo@nokia.com>2023-10-18 10:16:28 +0300
committerMatias Elo <matias.elo@nokia.com>2023-10-23 12:31:25 +0300
commit14915c20de199e2cda397b157cbba8a86c105d04 (patch)
treee47c8ea3f8e6652e2201a19b55b5a4e251c6d747 /configure.ac
parent303fb45b65e2ae9615a921935decdeeb728f9e97 (diff)
api: increment ODP API version to 1.42.1
Increment API version number to reflect the following changes: Backward compatible: - cls: add odp_cls_pmr_create_multi() function - cls: add odp_cls_pmr_destroy_multi() function - cls: add odp_cls_cos_create_multi() function - cls: add odp_cos_destroy_multi() function - crypto: clarify packet ordering of async crypto ops - crypto: add null_crypto crypto op flag for skipping crypto - crypto: allow both basic and out-of-place ops in one session - pktio: add ODP_PKTIO_MAX_INDEX define - queue: add odp_queue_create_multi() function - queue: add odp_queue_destroy_multi() function - queue: clarify odp_queue_param_t default value specification - system: add new ARMv8 and v9 enumerations - timer: clean up odp_timer_pool_param_t.num_timers description - timer: add odp_timeout_alloc_multi() function - timer: add odp_timeout_free_multi() function Helper library (1.4.0): Backward incompatible: - protocols: rename ODP_GTP_HLEN define to ODPH_GTP_HLEN - protocols: rename ODP_IGMP_HLEN define to ODPH_IGMP_HLEN - protocols: remove unused ICMP defines and add missing ODPH_ prefix to the remaining defines Backward compatible: - macros: add ODPH_MIN() and ODPH_MAX() helper macros - macros: add ODPH_ARRAY_SIZE() helper macro - macros: add ODPH_ABS() helper macro Signed-off-by: Matias Elo <matias.elo@nokia.com> Reviewed-by: Petri Savolainen <petri.savolainen@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 69290e34b..8459553b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_PREREQ([2.5])
##########################################################################
m4_define([odp_version_generation], [1])
m4_define([odp_version_major], [42])
-m4_define([odp_version_minor], [0])
+m4_define([odp_version_minor], [1])
m4_define([odp_version_patch], [0])
m4_define([odp_version_api],
@@ -27,7 +27,7 @@ AC_SUBST(ODP_VERSION_API)
# Helper library version
##########################################################################
m4_define([odph_version_generation], [1])
-m4_define([odph_version_major], [3])
+m4_define([odph_version_major], [4])
m4_define([odph_version_minor], [0])
m4_define([odph_version],