aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2017-09-18 14:05:13 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-10-03 11:52:09 +0300
commit0ff7861b8a958b5e23adc5b13783aeeff0629e03 (patch)
treed6823612fa8cfc0368d0ae08afa388be612a7179 /configure.ac
parentb4d17b1f6807cd980a1b2dd30573f17677ea371b (diff)
linux-gen: split arm into arm and aarch64
In preparation to arch-file cleanup split ARM architecture into 32-bit ARM and AArch64. Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7da75ec4..5bc84a71b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,7 +109,7 @@ AS_CASE([$host],
[i686*], [ARCH_DIR=x86],
[mips64*], [ARCH_DIR=mips64],
[powerpc*], [ARCH_DIR=powerpc],
- [aarch64*], [ARCH_DIR=arm],
+ [aarch64*], [ARCH_DIR=aarch64],
[arm*], [ARCH_DIR=arm],
[ARCH_DIR=undefined]
)
@@ -219,6 +219,7 @@ AM_CONDITIONAL([user_guide], [test "x${user_guides}" = "xyes" ])
AM_CONDITIONAL([HAVE_MSCGEN], [test "x${MSCGEN}" = "xmscgen"])
AM_CONDITIONAL([helper_linux], [test x$helper_linux = xyes ])
AM_CONDITIONAL([ARCH_IS_ARM], [test "x${ARCH_DIR}" = "xarm"])
+AM_CONDITIONAL([ARCH_IS_AARCH64], [test "x${ARCH_DIR}" = "xaarch64"])
AM_CONDITIONAL([ARCH_IS_MIPS64], [test "x${ARCH_DIR}" = "xmips64"])
AM_CONDITIONAL([ARCH_IS_POWERPC], [test "x${ARCH_DIR}" = "xpowerpc"])
AM_CONDITIONAL([ARCH_IS_X86], [test "x${ARCH_DIR}" = "xx86"])