summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasahisa Kojima <masahisa.kojima@linaro.org>2021-11-18 04:46:45 +0000
committerMasahisa Kojima <masahisa.kojima@linaro.org>2021-11-20 00:36:22 +0900
commit599dece3e940991aa173c89b3a2adaf07d16d8d2 (patch)
treebba1a1fdf48bea3a62b3f0ebe517a63f6e91b560
parent254fdbac9f58df4a29baba06e83b4ea2fff68bed (diff)
ledge-synquacer: update u-boot recipe for SynQuacer
This commit adds the missing U-Boot patch and updates synquacer_developerbox_defconfig to inculde ubootefi.var as a preseeded efi variable. Signed-off-by: Masahisa Kojima <masahisa.kojima@linaro.org>
-rw-r--r--recipes-bsp/u-boot/u-boot-ledge.bb10
-rw-r--r--recipes-bsp/u-boot/u-boot-ledge/0003-configs-synquacer-Fix-dfu_alt_info-to-use-nor1.patch33
-rw-r--r--recipes-bsp/u-boot/u-boot-ledge/synquacer_developerbox_defconfig5
3 files changed, 40 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ledge.bb b/recipes-bsp/u-boot/u-boot-ledge.bb
index b180d2a..31b273b 100644
--- a/recipes-bsp/u-boot/u-boot-ledge.bb
+++ b/recipes-bsp/u-boot/u-boot-ledge.bb
@@ -14,13 +14,11 @@ PV = "2021.10"
SRC_URI = "git://git.denx.de/u-boot.git"
SRCREV = "d80bb749fab53da72c4a0e09b8c2d2aaa3103c91"
-SRC_URI += " \
- file://0001-synquacer-add-fTPM-support.patch \
- file://0002-Revert-configs-synquacer-Make-U-Boot-binary-position.patch \
- file://ubootefi.var \
- "
+SRC_URI += " file://ubootefi.var"
-RM_WORK_EXCLUDE += "u-boot-ledge"
+SRC_URI_append_ledge-synquacer = " file://0001-synquacer-add-fTPM-support.patch"
+SRC_URI_append_ledge-synquacer = " file://0002-Revert-configs-synquacer-Make-U-Boot-binary-position.patch"
+SRC_URI_append_ledge-synquacer = " file://0003-configs-synquacer-Fix-dfu_alt_info-to-use-nor1.patch"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-ledge/0003-configs-synquacer-Fix-dfu_alt_info-to-use-nor1.patch b/recipes-bsp/u-boot/u-boot-ledge/0003-configs-synquacer-Fix-dfu_alt_info-to-use-nor1.patch
new file mode 100644
index 0000000..93c78f7
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ledge/0003-configs-synquacer-Fix-dfu_alt_info-to-use-nor1.patch
@@ -0,0 +1,33 @@
+From b0aaa45344067323b7cd9495b046731db19eff1a Mon Sep 17 00:00:00 2001
+From: Masami Hiramatsu <masami.hiramatsu@linaro.org>
+Date: Wed, 10 Nov 2021 09:40:07 +0900
+Subject: [PATCH 3/3] configs: synquacer: Fix dfu_alt_info to use nor1
+
+Fix dfu_alt_info to use nor1 instead of the device name.
+This reverts a part of commit 59bd18d4c4d7 ("configs: synquacer:
+Remove mtdparts settings and update DFU setting") because the
+commit a4f2d8341455 ("mtd: spi: nor: force mtd name to "nor%d"")
+changed the mtd device naming scheme to nor%d.
+
+Signed-off-by: Masami Hiramatsu <masami.hiramatsu@linaro.org>
+Acked-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
+---
+ include/configs/synquacer.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/configs/synquacer.h b/include/configs/synquacer.h
+index 4503cf3f6d..8fe10d7485 100644
+--- a/include/configs/synquacer.h
++++ b/include/configs/synquacer.h
+@@ -62,7 +62,7 @@
+ /* #define CONFIG_SYS_PCI_64BIT 1 */
+
+ #define DEFAULT_DFU_ALT_INFO "dfu_alt_info=" \
+- "mtd mx66u51235f=u-boot.bin raw 200000 100000;" \
++ "mtd nor1=u-boot.bin raw 200000 100000;" \
+ "fip.bin raw 180000 78000;" \
+ "optee.bin raw 500000 100000\0"
+
+--
+2.17.1
+
diff --git a/recipes-bsp/u-boot/u-boot-ledge/synquacer_developerbox_defconfig b/recipes-bsp/u-boot/u-boot-ledge/synquacer_developerbox_defconfig
index 142d29b..621072c 100644
--- a/recipes-bsp/u-boot/u-boot-ledge/synquacer_developerbox_defconfig
+++ b/recipes-bsp/u-boot/u-boot-ledge/synquacer_developerbox_defconfig
@@ -661,7 +661,7 @@ CONFIG_CMD_LOG=y
CONFIG_PARTITIONS=y
# CONFIG_MAC_PARTITION is not set
CONFIG_DOS_PARTITION=y
-# CONFIG_ISO_PARTITION is not set
+CONFIG_ISO_PARTITION=y
# CONFIG_AMIGA_PARTITION is not set
CONFIG_EFI_PARTITION=y
CONFIG_EFI_PARTITION_ENTRIES_NUMBERS=128
@@ -1633,7 +1633,8 @@ CONFIG_EFI_LOADER=y
CONFIG_CMD_BOOTEFI_BOOTMGR=y
CONFIG_EFI_VARIABLE_FILE_STORE=y
# CONFIG_EFI_MM_COMM_TEE is not set
-# CONFIG_EFI_VARIABLES_PRESEED is not set
+CONFIG_EFI_VARIABLES_PRESEED=y
+CONFIG_EFI_VAR_SEED_FILE="ubootefi.var"
CONFIG_EFI_VAR_BUF_SIZE=16384
CONFIG_EFI_GET_TIME=y
CONFIG_EFI_SET_TIME=y