aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorZygmunt Krynicki <zygmunt.krynicki@linaro.org>2011-01-26 14:36:15 +0100
committerZygmunt Krynicki <zygmunt.krynicki@linaro.org>2011-01-26 14:36:15 +0100
commitbe4ac6462b6d3a030efcde59b43ebc44839ed244 (patch)
treef9d1136d41f6f2a92dc1a79869cd02eddf87007a /setup.py
parentf5e7e049bd7af1a591c798b1b0154e518bd9a813 (diff)
Use the more recent versiontools interface
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 0482a50..2166d7a 100755
--- a/setup.py
+++ b/setup.py
@@ -19,13 +19,13 @@
# along with launch-control-tool. If not, see <http://www.gnu.org/licenses/>.
from setuptools import setup, find_packages
-
-from launch_control_tool import get_version
+import versiontools
+import launch_control_tool
setup(
name = 'launch-control-tool',
- version = get_version(),
+ version = versiontools.format_version(launch_control_tool.__version__),
author = "Zygmunt Krynicki",
author_email = "zygmunt.krynicki@linaro.org",
packages = find_packages(),
@@ -54,11 +54,11 @@ setup(
"Topic :: Software Development :: Testing",
],
install_requires = [
- 'versiontools >= 1.0.1',
+ 'versiontools >= 1.1.c1.dev21',
'argparse >= 1.1'
],
setup_requires = [
- 'versiontools >= 1.0.1',
+ 'versiontools >= 1.1.c1.dev21',
],
tests_require = [
],