summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2016-01-20 20:12:38 +0000
committerBen Hutchings <ben@decadent.org.uk>2016-01-20 21:44:14 +0000
commitd4febbd442f922f8cba7ea9c7207ecdfe6582efc (patch)
treea6fedc5df5d3f251fffecfa0a520840b232ebd2c /debian/rules
parent913a861175d65a5423f4de47c4a033b94485ec28 (diff)
Remove busybox hook in favour of busybox's own
- Set BUSYBOXDIR empty initially and let busybox's conf hook override it - Fail if BUSYBOX=y and BUSYBOXDIR remains empty after running conf hooks - Bump the minimum version to the first version that has the conf hook - Update the automatic selection of klibc utilities to check whether BUSYBOXDIR is empty Closes: #810154 Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ea2ff3b..d630547 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,8 +6,15 @@
# On Debian we can use either busybox or busybox-static, but on Ubuntu
# and derivatives only busybox-initramfs will work.
BUSYBOX_PACKAGES := $(shell if dpkg-vendor --derives-from ubuntu; then echo busybox-initramfs; else echo busybox busybox-static; fi)
-BUSYBOX_MIN_VERSION := 1:1.01-3
+BUSYBOX_MIN_VERSION := 1:1.22.0-17~
override_dh_gencontrol:
echo >> debian/initramfs-tools-core.substvars "busybox:Recommends=$(wordlist 2,100,$(BUSYBOX_PACKAGES:%=| % (>= $(BUSYBOX_MIN_VERSION))))"
dh_gencontrol
+
+override_dh_install:
+ sed -e 's,@BUSYBOX_PACKAGES@,$(wordlist 2,100,$(BUSYBOX_PACKAGES:%=or %)),' \
+ -e 's/@BUSYBOX_MIN_VERSION@/$(BUSYBOX_MIN_VERSION)/' \
+ mkinitramfs > debian/initramfs-tools-core/usr/sbin/mkinitramfs
+ chmod 755 debian/initramfs-tools-core/usr/sbin/mkinitramfs
+ dh_install