aboutsummaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorOlivier Naudan <o-naudan@ti.com>2012-04-13 09:08:41 -0400
committerOlivier Naudan <o-naudan@ti.com>2012-04-13 09:08:41 -0400
commit54399760aad93cb3ec36162ced7649c8cd8286db (patch)
tree3b6047cba24cc1323720e162b5906e3fe8abdfc4 /tools/Makefile.am
parentbeb43201c942afa12dfc4225218b61fcd6e90923 (diff)
Imported Upstream version 0.11.90upstream/0.11.90
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am56
1 files changed, 28 insertions, 28 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 8fe194c..1c60b73 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,45 +1,45 @@
bin_PROGRAMS = \
- gst-inspect-@GST_MAJORMINOR@ \
- gst-typefind-@GST_MAJORMINOR@
+ gst-inspect-@GST_API_VERSION@ \
+ gst-typefind-@GST_API_VERSION@
-gst_inspect_@GST_MAJORMINOR@_SOURCES = gst-inspect.c tools.h
-gst_inspect_@GST_MAJORMINOR@_CFLAGS = $(GST_OBJ_CFLAGS)
-gst_inspect_@GST_MAJORMINOR@_LDADD = $(GST_OBJ_LIBS)
+gst_inspect_@GST_API_VERSION@_SOURCES = gst-inspect.c tools.h
+gst_inspect_@GST_API_VERSION@_CFLAGS = $(GST_OBJ_CFLAGS)
+gst_inspect_@GST_API_VERSION@_LDADD = $(GST_OBJ_LIBS)
-gst_typefind_@GST_MAJORMINOR@_SOURCES = gst-typefind.c tools.h
-gst_typefind_@GST_MAJORMINOR@_CFLAGS = $(GST_OBJ_CFLAGS)
-gst_typefind_@GST_MAJORMINOR@_LDADD = $(GST_OBJ_LIBS)
+gst_typefind_@GST_API_VERSION@_SOURCES = gst-typefind.c tools.h
+gst_typefind_@GST_API_VERSION@_CFLAGS = $(GST_OBJ_CFLAGS)
+gst_typefind_@GST_API_VERSION@_LDADD = $(GST_OBJ_LIBS)
if !GST_DISABLE_PARSE
-bin_PROGRAMS += gst-launch-@GST_MAJORMINOR@
+bin_PROGRAMS += gst-launch-@GST_API_VERSION@
-gst_launch_@GST_MAJORMINOR@_SOURCES = gst-launch.c tools.h
-gst_launch_@GST_MAJORMINOR@_CFLAGS = $(GST_OBJ_CFLAGS)
-gst_launch_@GST_MAJORMINOR@_LDADD = $(GST_OBJ_LIBS)
+gst_launch_@GST_API_VERSION@_SOURCES = gst-launch.c tools.h
+gst_launch_@GST_API_VERSION@_CFLAGS = $(GST_OBJ_CFLAGS)
+gst_launch_@GST_API_VERSION@_LDADD = $(GST_OBJ_LIBS)
endif
Android.mk: Makefile.am
androgenizer -:PROJECT gstreamer \
-:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
- -:EXECUTABLE gst-inspect-@GST_MAJORMINOR@ -:TAGS eng debug \
- -:SOURCES $(gst_inspect_@GST_MAJORMINOR@_SOURCES) \
- -:CFLAGS $(DEFS) $(gst_inspect_@GST_MAJORMINOR@_CFLAGS) \
- -:LDFLAGS $(gst_inspect_@GST_MAJORMINOR@_LDADD) \
+ -:EXECUTABLE gst-inspect-@GST_API_VERSION@ -:TAGS eng debug \
+ -:SOURCES $(gst_inspect_@GST_API_VERSION@_SOURCES) \
+ -:CFLAGS $(DEFS) $(gst_inspect_@GST_API_VERSION@_CFLAGS) \
+ -:LDFLAGS $(gst_inspect_@GST_API_VERSION@_LDADD) \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
- -:EXECUTABLE gst-launch-@GST_MAJORMINOR@ -:TAGS eng debug \
- -:SOURCES $(gst_launch_@GST_MAJORMINOR@_SOURCES) \
- -:CFLAGS $(DEFS) $(gst_launch_@GST_MAJORMINOR@_CFLAGS) \
- -:LDFLAGS $(gst_launch_@GST_MAJORMINOR@_LDADD) \
+ -:EXECUTABLE gst-launch-@GST_API_VERSION@ -:TAGS eng debug \
+ -:SOURCES $(gst_launch_@GST_API_VERSION@_SOURCES) \
+ -:CFLAGS $(DEFS) $(gst_launch_@GST_API_VERSION@_CFLAGS) \
+ -:LDFLAGS $(gst_launch_@GST_API_VERSION@_LDADD) \
-:PASSTHROUGH LOCAL_ARM_MODE:=arm \
> $@
manpages = \
- gst-inspect-@GST_MAJORMINOR@.1 \
- gst-typefind-@GST_MAJORMINOR@.1
+ gst-inspect-@GST_API_VERSION@.1 \
+ gst-typefind-@GST_API_VERSION@.1
if !GST_DISABLE_PARSE
-manpages += gst-launch-@GST_MAJORMINOR@.1
+manpages += gst-launch-@GST_API_VERSION@.1
endif
CLEANFILES = $(manpages) *.gcno *.gcda
@@ -57,11 +57,11 @@ EXTRA_DIST = \
gst-typefind.1.in \
gst-plot-timeline.py
-%-@GST_MAJORMINOR@.1: %.1.in
+%-@GST_API_VERSION@.1: %.1.in
$(AM_V_GEN)sed \
- -e s,gst-inspect,gst-inspect-@GST_MAJORMINOR@,g \
- -e s,gst-launch,gst-launch-@GST_MAJORMINOR@,g \
- -e s,gst-typefind,gst-typefind-@GST_MAJORMINOR@,g \
- -e s,GST_MAJORMINOR,@GST_MAJORMINOR@,g \
+ -e s,gst-inspect,gst-inspect-@GST_API_VERSION@,g \
+ -e s,gst-launch,gst-launch-@GST_API_VERSION@,g \
+ -e s,gst-typefind,gst-typefind-@GST_API_VERSION@,g \
+ -e s,GST_API_VERSION,@GST_API_VERSION@,g \
$< >$@