aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2012-05-14 12:48:31 -0600
committerLeann Ogasawara <leann.ogasawara@canonical.com>2012-05-21 06:46:52 -0700
commit896ba50552e54f2a4721f6deda8d1757a74f4fa5 (patch)
tree2feb0c41c5b27dd2f01e4c81d230b6df7cba7a96 /debian
parent9ae60ce6f19f8817c4577f487975b54b05b7bf03 (diff)
UBUNTU: [Config] perarch and indep tools builds need separate build directories
We are losing the perarch perf binary etc when building, this is occuring based on parallel execution order. This occurs because both build passes use 'debian/build/tools' as their build directory. This is simply not safe as execution order is not guarenteed. Move the perarch build to tools-perarch to avoid collisions. Signed-off-by: Andy Whitcroft <apw@canonical.com> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk28
1 files changed, 15 insertions, 13 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index c2e57fbd24c..71c9b850361 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -385,26 +385,28 @@ endif
#
# per-architecture packages
#
+builddirpa = $(builddir)/tools-perarch
+
$(stampdir)/stamp-prepare-perarch:
@echo Debug: $@
ifeq ($(do_tools),true)
- rm -rf $(builddir)/tools
- install -d $(builddir)/tools
- for i in *; do ln -s $(CURDIR)/$$i $(builddir)/tools/; done
- rm $(builddir)/tools/tools
- rsync -a tools/ $(builddir)/tools/tools/
+ rm -rf $(builddirpa)
+ install -d $(builddirpa)
+ for i in *; do ln -s $(CURDIR)/$$i $(builddirpa); done
+ rm $(builddirpa)/tools
+ rsync -a tools/ $(builddirpa)/tools/
endif
touch $@
$(stampdir)/stamp-build-perarch: $(stampdir)/stamp-prepare-perarch
@echo Debug: $@
ifeq ($(do_tools),true)
- cd $(builddir)/tools/tools/perf && \
+ cd $(builddirpa)/tools/perf && \
make HAVE_CPLUS_DEMANGLE=1 CROSS_COMPILE=$(CROSS_COMPILE) $(conc_level)
if [ "$(arch)" = "amd64" ] || [ "$(arch)" = "i386" ]; then \
- cd $(builddir)/tools/tools/power/x86/x86_energy_perf_policy && make CROSS_COMPILE=$(CROSS_COMPILE); \
- cd $(builddir)/tools/tools/power/x86/turbostat && make CROSS_COMPILE=$(CROSS_COMPILE); \
- cd $(builddir)/tools/tools/hv && make CROSS_COMPILE=$(CROSS_COMPILE) CFLAGS=-I../../include; \
+ cd $(builddirpa)/tools/power/x86/x86_energy_perf_policy && make CROSS_COMPILE=$(CROSS_COMPILE); \
+ cd $(builddirpa)/tools/power/x86/turbostat && make CROSS_COMPILE=$(CROSS_COMPILE); \
+ cd $(builddirpa)/tools/hv && make CROSS_COMPILE=$(CROSS_COMPILE) CFLAGS=-I../../include; \
fi
endif
@touch $@
@@ -415,15 +417,15 @@ install-perarch: $(stampdir)/stamp-build-perarch
# Add the tools.
ifeq ($(do_tools),true)
install -d $(toolspkgdir)/usr/bin
- install -s -m755 $(builddir)/tools/tools/perf/perf \
+ install -s -m755 $(builddirpa)/tools/perf/perf \
$(toolspkgdir)/usr/bin/perf_$(abi_release)
if [ "$(arch)" = "amd64" ] || [ "$(arch)" = "i386" ]; then \
- install -s -m755 $(builddir)/tools/tools/power/x86/x86_energy_perf_policy/x86_energy_perf_policy \
+ install -s -m755 $(builddirpa)/tools/power/x86/x86_energy_perf_policy/x86_energy_perf_policy \
$(toolspkgdir)/usr/bin/x86_energy_perf_policy_$(abi_release); \
- install -s -m755 $(builddir)/tools/tools/power/x86/turbostat/turbostat \
+ install -s -m755 $(builddirpa)/tools/power/x86/turbostat/turbostat \
$(toolspkgdir)/usr/bin/turbostat_$(abi_release); \
install -d $(toolspkgdir)/usr/sbin; \
- install -s -m755 $(builddir)/tools/tools/hv/hv_kvp_daemon \
+ install -s -m755 $(builddirpa)/tools/hv/hv_kvp_daemon \
$(toolspkgdir)/usr/sbin/hv_kvp_daemon_$(abi_release); \
fi
endif