aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2011-04-08 12:10:34 -0700
committerJohn Rigby <john.rigby@linaro.org>2011-07-25 14:37:58 -0600
commitc9ac4856abb31408e336765739b4682e49775248 (patch)
treeaf2688a751b9be960fd446d37c0bc82c1728f1a7 /debian
parentabdfe08636cc8b3946b014cbdb127dfd59603c2f (diff)
UBUNTU: [Config] Make linux-libc-dev coinstallable under multiarch
BugLink: http://bugs.launchpad.net/bugs/750585 Signed-off-by: Steve Langasek <slangasek@ubuntu.com> Signed-off-by: Tim Gardner <tim.gardner@canonical.com> Signed-off-by: Leann Ogasawara <leann.ogasawara@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/0-common-vars.mk1
-rw-r--r--debian/rules.d/2-binary-arch.mk2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 66fcec37e89..05a6ad74b91 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -96,6 +96,7 @@ endif
# committing changes to the top level Makefile
SUBLEVEL := $(shell echo $(release) | awk -F. '{print $$3}')
+DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_ARCH = $(shell dpkg-architecture -qDEB_HOST_ARCH)
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 9765ef740e9..cf112cde34c 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -245,6 +245,8 @@ install-arch-headers:
find . -name '.' -o -name '.*' -prune -o -print | \
cpio -pvd --preserve-modification-time \
$(headers_dir)/usr/include/ )
+ mkdir $(headers_dir)/usr/include/$(DEB_HOST_MULTIARCH)
+ mv $(headers_dir)/usr/include/asm $(headers_dir)/usr/include/$(DEB_HOST_MULTIARCH)/
rm -rf $(headers_tmp)