aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2011-04-08 12:10:34 -0700
committerJohn Rigby <john.rigby@linaro.org>2011-09-12 09:04:19 -0600
commitb3d1bb6b0741609d50ff6f3edb8498e3ab60bf29 (patch)
tree66ec35a7cf4dfc1dc681238188094d8b6316a471 /debian
parenta12764b661beb781a221ff96d607df6c1805f184 (diff)
UBUNTU: [Config] Make linux-libc-dev coinstallable under multiarch
BugLink: http://bugs.launchpad.net/bugs/750585 Signed-off-by: Steve Langasek <slangasek@ubuntu.com> Signed-off-by: Tim Gardner <tim.gardner@canonical.com> Signed-off-by: Leann Ogasawara <leann.ogasawara@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/0-common-vars.mk1
-rw-r--r--debian/rules.d/2-binary-arch.mk2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules.d/0-common-vars.mk b/debian/rules.d/0-common-vars.mk
index 66fcec37e89..05a6ad74b91 100644
--- a/debian/rules.d/0-common-vars.mk
+++ b/debian/rules.d/0-common-vars.mk
@@ -96,6 +96,7 @@ endif
# committing changes to the top level Makefile
SUBLEVEL := $(shell echo $(release) | awk -F. '{print $$3}')
+DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_ARCH = $(shell dpkg-architecture -qDEB_HOST_ARCH)
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 9765ef740e9..cf112cde34c 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -245,6 +245,8 @@ install-arch-headers:
find . -name '.' -o -name '.*' -prune -o -print | \
cpio -pvd --preserve-modification-time \
$(headers_dir)/usr/include/ )
+ mkdir $(headers_dir)/usr/include/$(DEB_HOST_MULTIARCH)
+ mv $(headers_dir)/usr/include/asm $(headers_dir)/usr/include/$(DEB_HOST_MULTIARCH)/
rm -rf $(headers_tmp)