aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStefan Bader <stefan.bader@canonical.com>2011-08-16 16:49:35 +0200
committerJohn Rigby <john.rigby@linaro.org>2011-09-12 09:09:10 -0600
commit818397429c564f7b86496592bb672bb194b9c504 (patch)
treebb9b0bea9ffe24de80edffc637361ad19e52d864 /debian
parent37f0d24c0a69f2196d3186bf2d269a5e8c8d6fe1 (diff)
UBUNTU: [Config] Force perf to use libiberty for demangling
Because libbfd is GPLv3 only and perf is GPLv2 only. Also this avoids statically linking against libbfd to allow multiple versions of perf being installed in parallel. See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=606050 BugLink: http://bugs.launchpad.net/bugs/783660 Signed-off-by: Stefan Bader <stefan.bader@canonical.com> Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 29788fcc7a5..466c8a4d4ee 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -365,7 +365,8 @@ endif
$(stampdir)/stamp-build-perarch: prepare-perarch
ifeq ($(do_tools),true)
- cd $(builddir)/tools/tools/perf && make $(CROSS_COMPILE)
+ cd $(builddir)/tools/tools/perf && \
+ make HAVE_CPLUS_DEMANGLE=1 $(CROSS_COMPILE)
if [ "$(arch)" = "amd64" ] || [ "$(arch)" = "i386" ]; then \
cd $(builddir)/tools/tools/power/x86/x86_energy_perf_policy && make $(CROSS_COMPILE); \
cd $(builddir)/tools/tools/power/x86/turbostat && make $(CROSS_COMPILE); \